aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-twisted/patches
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-04-19 20:18:45 +0800
committerJeffery To <jeffery.to@gmail.com>2019-04-19 20:18:45 +0800
commit9fb2d52191d214b58e08c098de0feec393dddfe1 (patch)
treed215c69f48145c2fe96136dac49fafee854ec3ee /lang/python/python-twisted/patches
parentd8f0f87ac9f468e00d7d916cf109b01ebc4d1023 (diff)
python-twisted: Update to 19.2.0, refresh patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-twisted/patches')
-rw-r--r--lang/python/python-twisted/patches/001-omit-tkconch.patch2
-rw-r--r--lang/python/python-twisted/patches/002-omit-tests.patch12
2 files changed, 7 insertions, 7 deletions
diff --git a/lang/python/python-twisted/patches/001-omit-tkconch.patch b/lang/python/python-twisted/patches/001-omit-tkconch.patch
index 1ec4baf0f..a5bddaaec 100644
--- a/lang/python/python-twisted/patches/001-omit-tkconch.patch
+++ b/lang/python/python-twisted/patches/001-omit-tkconch.patch
@@ -1,6 +1,6 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
-@@ -144,7 +144,6 @@ _CONSOLE_SCRIPTS = [
+@@ -147,7 +147,6 @@ _CONSOLE_SCRIPTS = [
"conch = twisted.conch.scripts.conch:run",
"mailmail = twisted.mail.scripts.mailmail:run",
"pyhtmlizer = twisted.scripts.htmlizer:run",
diff --git a/lang/python/python-twisted/patches/002-omit-tests.patch b/lang/python/python-twisted/patches/002-omit-tests.patch
index 33ba77a0f..83ca2cd76 100644
--- a/lang/python/python-twisted/patches/002-omit-tests.patch
+++ b/lang/python/python-twisted/patches/002-omit-tests.patch
@@ -1,18 +1,18 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
-@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, object):
-
+@@ -173,11 +173,6 @@ class ConditionalExtension(Extension, ob
# The C extensions used for Twisted.
_EXTENSIONS = [
-- ConditionalExtension(
+ ConditionalExtension(
- "twisted.test.raiser",
- sources=["src/twisted/test/raiser.c"],
- condition=lambda _: _isCPython),
-
- ConditionalExtension(
+- ConditionalExtension(
"twisted.internet.iocpreactor.iocpsupport",
sources=[
-@@ -238,12 +233,11 @@ def getSetupArgs(extensions=_EXTENSIONS):
+ "src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
+@@ -241,12 +236,11 @@ def getSetupArgs(extensions=_EXTENSIONS)
"incremental >= 16.10.1",
"Automat >= 0.3.0",
"hyperlink >= 17.1.1",
@@ -26,7 +26,7 @@
use_incremental=True,
setup_requires=["incremental >= 16.10.1"],
install_requires=requirements,
-@@ -253,7 +247,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
+@@ -256,7 +250,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
cmdclass=command_classes,
include_package_data=True,
exclude_package_data={