aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-twisted/patches
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-03-23 23:17:45 +0800
committerJeffery To <jeffery.to@gmail.com>2020-03-23 23:17:45 +0800
commit633c81e7a934c6e8820623c596b8815d810786ea (patch)
tree3b127e9067f6e1080d959d885b21001adec062bd /lang/python/python-twisted/patches
parent6408a0c585eb08e61492c67d724715cf18706bf2 (diff)
python-twisted: Update to 20.3.0, refresh patches
This update includes fixes for: * CVE-2020-10108 * CVE-2020-10109 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-twisted/patches')
-rw-r--r--lang/python/python-twisted/patches/001-omit-tkconch.patch2
-rw-r--r--lang/python/python-twisted/patches/002-omit-tests.patch16
2 files changed, 9 insertions, 9 deletions
diff --git a/lang/python/python-twisted/patches/001-omit-tkconch.patch b/lang/python/python-twisted/patches/001-omit-tkconch.patch
index c975aa31a..4f376ed49 100644
--- a/lang/python/python-twisted/patches/001-omit-tkconch.patch
+++ b/lang/python/python-twisted/patches/001-omit-tkconch.patch
@@ -1,6 +1,6 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
-@@ -150,7 +150,6 @@ _CONSOLE_SCRIPTS = [
+@@ -151,7 +151,6 @@ _CONSOLE_SCRIPTS = [
"conch = twisted.conch.scripts.conch:run",
"mailmail = twisted.mail.scripts.mailmail:run",
"pyhtmlizer = twisted.scripts.htmlizer:run",
diff --git a/lang/python/python-twisted/patches/002-omit-tests.patch b/lang/python/python-twisted/patches/002-omit-tests.patch
index 2eb84d06a..71501df14 100644
--- a/lang/python/python-twisted/patches/002-omit-tests.patch
+++ b/lang/python/python-twisted/patches/002-omit-tests.patch
@@ -1,6 +1,6 @@
--- a/src/twisted/python/_setup.py
+++ b/src/twisted/python/_setup.py
-@@ -176,11 +176,6 @@ class ConditionalExtension(Extension, ob
+@@ -177,11 +177,6 @@ class ConditionalExtension(Extension, ob
# The C extensions used for Twisted.
_EXTENSIONS = [
ConditionalExtension(
@@ -12,12 +12,12 @@
"twisted.internet.iocpreactor.iocpsupport",
sources=[
"src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
-@@ -285,12 +280,11 @@ def getSetupArgs(extensions=_EXTENSIONS,
- "incremental >= 16.10.1",
- "Automat >= 0.3.0",
- "hyperlink >= 17.1.1",
-- "PyHamcrest >= 1.9.0",
- "attrs >= 17.4.0",
+@@ -275,12 +270,11 @@ def getSetupArgs(extensions=_EXTENSIONS,
+ # PyHamcrest 1.10.0 is Python 3 only, but lacks package metadata that
+ # says so. This condition can be dropped when Twisted drops support for
+ # Python 2.7.
+- "PyHamcrest >= 1.9.0, != 1.10.0",
+ "attrs >= 19.2.0",
]
arguments.update(dict(
@@ -26,7 +26,7 @@
use_incremental=True,
setup_requires=["incremental >= 16.10.1"],
install_requires=requirements,
-@@ -300,7 +294,7 @@ def getSetupArgs(extensions=_EXTENSIONS,
+@@ -290,7 +284,7 @@ def getSetupArgs(extensions=_EXTENSIONS,
cmdclass=command_classes,
include_package_data=True,
exclude_package_data={