aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-twisted/patches
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2021-06-12 06:18:50 +0800
committerJeffery To <jeffery.to@gmail.com>2021-06-12 06:18:50 +0800
commit4b6e05d1fdd886133c982247f616115ef401e38c (patch)
tree3daa142068689b16a60da5833bbee02bc4e157f4 /lang/python/python-twisted/patches
parent8c0777e3bbb0c8c74a3490fc8221cd8ad0cf8348 (diff)
python-twisted: Update to 21.2.0, redo patches
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-twisted/patches')
-rw-r--r--lang/python/python-twisted/patches/001-omit-tkconch.patch20
-rw-r--r--lang/python/python-twisted/patches/002-omit-tests.patch55
2 files changed, 29 insertions, 46 deletions
diff --git a/lang/python/python-twisted/patches/001-omit-tkconch.patch b/lang/python/python-twisted/patches/001-omit-tkconch.patch
index 4f376ed49..8aee0fd6b 100644
--- a/lang/python/python-twisted/patches/001-omit-tkconch.patch
+++ b/lang/python/python-twisted/patches/001-omit-tkconch.patch
@@ -1,13 +1,13 @@
---- a/src/twisted/python/_setup.py
-+++ b/src/twisted/python/_setup.py
-@@ -151,7 +151,6 @@ _CONSOLE_SCRIPTS = [
- "conch = twisted.conch.scripts.conch:run",
- "mailmail = twisted.mail.scripts.mailmail:run",
- "pyhtmlizer = twisted.scripts.htmlizer:run",
-- "tkconch = twisted.conch.scripts.tkconch:run",
- "trial = twisted.scripts.trial:run",
- "twist = twisted.application.twist._twist:Twist.main",
- "twistd = twisted.scripts.twistd:run",
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -98,7 +98,6 @@ console_scripts =
+ conch = twisted.conch.scripts.conch:run
+ mailmail = twisted.mail.scripts.mailmail:run
+ pyhtmlizer = twisted.scripts.htmlizer:run
+- tkconch = twisted.conch.scripts.tkconch:run
+ trial = twisted.scripts.trial:run
+ twist = twisted.application.twist._twist:Twist.main
+ twistd = twisted.scripts.twistd:run
--- a/src/twisted/python/twisted-completion.zsh
+++ b/src/twisted/python/twisted-completion.zsh
@@ -1,4 +1,4 @@
diff --git a/lang/python/python-twisted/patches/002-omit-tests.patch b/lang/python/python-twisted/patches/002-omit-tests.patch
index 71501df14..54397cc00 100644
--- a/lang/python/python-twisted/patches/002-omit-tests.patch
+++ b/lang/python/python-twisted/patches/002-omit-tests.patch
@@ -1,37 +1,20 @@
---- a/src/twisted/python/_setup.py
-+++ b/src/twisted/python/_setup.py
-@@ -177,11 +177,6 @@ class ConditionalExtension(Extension, ob
- # The C extensions used for Twisted.
- _EXTENSIONS = [
- ConditionalExtension(
-- "twisted.test.raiser",
-- sources=["src/twisted/test/raiser.c"],
-- condition=lambda _: _isCPython),
--
-- ConditionalExtension(
- "twisted.internet.iocpreactor.iocpsupport",
- sources=[
- "src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
-@@ -275,12 +270,11 @@ def getSetupArgs(extensions=_EXTENSIONS,
- # PyHamcrest 1.10.0 is Python 3 only, but lacks package metadata that
- # says so. This condition can be dropped when Twisted drops support for
- # Python 2.7.
-- "PyHamcrest >= 1.9.0, != 1.10.0",
- "attrs >= 19.2.0",
- ]
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -90,6 +90,9 @@ osx_platform =
- arguments.update(dict(
-- packages=find_packages("src"),
-+ packages=find_packages("src", exclude=["*.test", "*.test.*"]),
- use_incremental=True,
- setup_requires=["incremental >= 16.10.1"],
- install_requires=requirements,
-@@ -290,7 +284,7 @@ def getSetupArgs(extensions=_EXTENSIONS,
- cmdclass=command_classes,
- include_package_data=True,
- exclude_package_data={
-- "": ["*.c", "*.h", "*.pxi", "*.pyx", "build.bat"],
-+ "": ["*.c", "*.h", "*.pxi", "*.pyx", "build.bat", "test/*"],
- },
- zip_safe=False,
- extras_require=_EXTRAS_REQUIRE,
+ [options.packages.find]
+ where = src
++exclude =
++ *.test
++ *.test.*
+
+ [options.entry_points]
+ console_scripts =
+@@ -109,6 +112,7 @@ console_scripts =
+ *.pxi
+ *.pyx
+ build.bat
++ test/*
+
+ [flake8]
+ disable-noqa = True