aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-trio
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-08-25 01:31:14 +0800
committerTianling Shen <cnsztl@gmail.com>2023-08-31 16:15:37 +0800
commit6b6ea7efe1c8e2584a0c788f06ef826f1030c6e9 (patch)
tree404ab6f78f71f9f3cb3046b321d733262ad19356 /lang/python/python-trio
parente7a8d18385e6d1de27d0501940259ab23e50be6f (diff)
python-trio: Update to 0.22.2, update list of dependencies
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-trio')
-rw-r--r--lang/python/python-trio/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/lang/python/python-trio/Makefile b/lang/python/python-trio/Makefile
index 8afd6b29a..d90f1b8f8 100644
--- a/lang/python/python-trio/Makefile
+++ b/lang/python/python-trio/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-trio
-PKG_VERSION:=0.22.0
+PKG_VERSION:=0.22.2
PKG_RELEASE:=1
PYPI_NAME:=trio
-PKG_HASH:=ce68f1c5400a47b137c5a4de72c7c901bd4e7a24fbdebfe9b41de8c6c04eaacf
+PKG_HASH:=3887cf18c8bcc894433420305468388dac76932e9668afa1c49aa3806b6accb3
-PKG_LICENSE:=Apache-2.0|MIT
-PKG_LICENSE_FILES:=LICENSE.APACHE2|LICENSE.MIT
+PKG_LICENSE:=Apache-2.0 MIT
+PKG_LICENSE_FILES:=LICENSE.APACHE2 LICENSE.MIT
PKG_MAINTAINER:=Julien Malik <julien.malik@paraiso.me>
include ../pypi.mk
@@ -26,14 +26,11 @@ define Package/python3-trio
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
- TITLE:=A friendly Python library for async concurrency and I/O
- URL:=https://trio.readthedocs.io
+ TITLE:=Friendly library for async concurrency and I/O
+ URL:=https://github.com/python-trio/trio
DEPENDS:= \
+python3-light \
+python3-attrs \
- +python3-async-generator \
- +python3-cffi \
- +python3-exceptiongroup \
+python3-idna \
+python3-outcome \
+python3-sniffio \
@@ -41,7 +38,8 @@ define Package/python3-trio
endef
define Package/python3-trio/description
- The Trio project’s goal is to produce a production-quality, permissively licensed, async/await-native I/O library for Python
+The Trio project’s goal is to produce a production-quality, permissively
+licensed, async/await-native I/O library for Python.
endef
$(eval $(call Py3Package,python3-trio))