aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-trio
diff options
context:
space:
mode:
authorJulien Malik <julien.malik@paraiso.me>2022-11-26 15:24:05 +0100
committerJulien Malik <julien.malik@paraiso.me>2022-11-26 15:24:05 +0100
commit07e29c3782f5eb4fb0e3cc3cdf587c77eafb96e6 (patch)
treea3cc4dcdca669395df018070fda42e3facfa01ae /lang/python/python-trio
parentf35f4dace76761048ab43edd91ca6c44123ff6ac (diff)
python-trio: add package for 0.22.0
Signed-off-by: Julien Malik <julien.malik@paraiso.me>
Diffstat (limited to 'lang/python/python-trio')
-rw-r--r--lang/python/python-trio/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/lang/python/python-trio/Makefile b/lang/python/python-trio/Makefile
new file mode 100644
index 000000000..8afd6b29a
--- /dev/null
+++ b/lang/python/python-trio/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2022 Julien Malik <julien.malik@paraiso.me>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-trio
+PKG_VERSION:=0.22.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=trio
+PKG_HASH:=ce68f1c5400a47b137c5a4de72c7c901bd4e7a24fbdebfe9b41de8c6c04eaacf
+
+PKG_LICENSE:=Apache-2.0|MIT
+PKG_LICENSE_FILES:=LICENSE.APACHE2|LICENSE.MIT
+PKG_MAINTAINER:=Julien Malik <julien.malik@paraiso.me>
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-trio
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=A friendly Python library for async concurrency and I/O
+ URL:=https://trio.readthedocs.io
+ DEPENDS:= \
+ +python3-light \
+ +python3-attrs \
+ +python3-async-generator \
+ +python3-cffi \
+ +python3-exceptiongroup \
+ +python3-idna \
+ +python3-outcome \
+ +python3-sniffio \
+ +python3-sortedcontainers
+endef
+
+define Package/python3-trio/description
+ The Trio project’s goal is to produce a production-quality, permissively licensed, async/await-native I/O library for Python
+endef
+
+$(eval $(call Py3Package,python3-trio))
+$(eval $(call BuildPackage,python3-trio))
+$(eval $(call BuildPackage,python3-trio-src))