aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-sqlalchemy
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-08-25 01:20:57 +0800
committerTianling Shen <cnsztl@gmail.com>2023-08-31 16:14:50 +0800
commit8b6a817af298364134f3ec37cbb8bfda48b2a35f (patch)
treeb833da1d59e6000c09095ff0e11b25c0de9aeaed /lang/python/python-sqlalchemy
parent1ec68a6e98ec0c1a7256023baee1f9b01ccbf5d2 (diff)
python-sqlalchemy: Update to 2.0.20, update list of dependencies
This also adds a build dependency on python-cython/host. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-sqlalchemy')
-rw-r--r--lang/python/python-sqlalchemy/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/lang/python/python-sqlalchemy/Makefile b/lang/python/python-sqlalchemy/Makefile
index f15cbb3ff..403151ed2 100644
--- a/lang/python/python-sqlalchemy/Makefile
+++ b/lang/python/python-sqlalchemy/Makefile
@@ -8,17 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-sqlalchemy
-PKG_VERSION:=1.4.22
+PKG_VERSION:=2.0.20
PKG_RELEASE:=1
PYPI_NAME:=SQLAlchemy
-PKG_HASH:=ec1be26cdccd60d180359a527d5980d959a26269a2c7b1b327a1eea0cab37ed8
+PKG_HASH:=ca8a5ff2aa7f3ade6c498aaafce25b1eaeabe4e42b73e25519183e4566a16fc6
PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:sqlalchemy:sqlalchemy
+PKG_BUILD_DEPENDS:=python-cython/host
+
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
@@ -29,19 +31,15 @@ define Package/python3-sqlalchemy
SUBMENU:=Python
TITLE:=Database Abstraction Library
URL:=https://www.sqlalchemy.org
- DEPENDS:= \
- +python3-light \
- +python3-urllib \
- +python3-decimal \
- +python3-logging
+ DEPENDS:=+python3 +python3-typing-extensions
endef
define Package/python3-sqlalchemy/description
- SQLAlchemy is the Python SQL toolkit and Object Relational Mapper
- that gives application developers the full power and flexibility of SQL.
- SQLAlchemy provides a full suite of well known enterprise-level persistence patterns,
- designed for efficient and high-performing database access,
- adapted into a simple and Pythonic domain language.
+SQLAlchemy is the Python SQL toolkit and Object Relational Mapper that
+gives application developers the full power and flexibility of SQL.
+SQLAlchemy provides a full suite of well known enterprise-level
+persistence patterns, designed for efficient and high-performing
+database access, adapted into a simple and Pythonic domain language.
endef
$(eval $(call Py3Package,python3-sqlalchemy))