aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-sqlalchemy
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-21 03:03:12 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-30 23:16:18 +0800
commit635cb1309c4d52763c03bc00e7c367e06908b54f (patch)
treef4ab5d3c372741d39b2c0c9e9e34a0c007ca6d53 /lang/python/python-sqlalchemy
parent29ef2938d131ad862f28c2e6f09656351a4ca006 (diff)
treewide: Use pypi.mk for Python packages
This updates all Python packages that download their source from PyPi to use pypi.mk. This will allow future improvements/changes to pypi.mk to affect all relevant packages. This also makes it easier for future Python packages to start using pypi.mk, when it's clear how it is used in existing packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-sqlalchemy')
-rw-r--r--lang/python/python-sqlalchemy/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/lang/python/python-sqlalchemy/Makefile b/lang/python/python-sqlalchemy/Makefile
index 451e8db57..8ddf4e840 100644
--- a/lang/python/python-sqlalchemy/Makefile
+++ b/lang/python/python-sqlalchemy/Makefile
@@ -11,16 +11,15 @@ PKG_NAME:=python-sqlalchemy
PKG_VERSION:=1.3.7
PKG_RELEASE:=1
-PKG_SOURCE:=SQLAlchemy-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/S/SQLAlchemy/
+PYPI_NAME:=SQLAlchemy
PKG_HASH:=0459bf0ea6478f3e904de074d65769a11d74cdc34438ab3159250c96d089aef0
-PKG_BUILD_DIR:=$(BUILD_DIR)/SQLAlchemy-$(PKG_VERSION)
PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:sqlalchemy:sqlalchemy
+include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk