aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-sniffio
diff options
context:
space:
mode:
authorJulien Malik <julien.malik@paraiso.me>2022-11-26 15:24:04 +0100
committerJulien Malik <julien.malik@paraiso.me>2022-11-26 15:24:04 +0100
commitf35f4dace76761048ab43edd91ca6c44123ff6ac (patch)
tree7bd888ce5a8d2d343fb0299f42e5ef7a248f7c6a /lang/python/python-sniffio
parent750facea90aafb75c5937259671369a83e43881a (diff)
python-sniffio: add package for 1.3.0
Signed-off-by: Julien Malik <julien.malik@paraiso.me>
Diffstat (limited to 'lang/python/python-sniffio')
-rw-r--r--lang/python/python-sniffio/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/lang/python/python-sniffio/Makefile b/lang/python/python-sniffio/Makefile
new file mode 100644
index 000000000..eef65ad6e
--- /dev/null
+++ b/lang/python/python-sniffio/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2022 Julien Malik <julien.malik@paraiso.me>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-sniffio
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=sniffio
+PKG_HASH:=e60305c5e5d314f5389259b7f22aaa33d8f7dee49763119234af3755c55b9101
+
+PKG_LICENSE:=Apache-2.0|MIT
+PKG_LICENSE_FILES:=LICENSE.APACHE2|LICENSE.MIT
+PKG_MAINTAINER:=Julien Malik <julien.malik@paraiso.me>
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-sniffio
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Sniff out which async library your code is running under
+ URL:=https://sniffio.readthedocs.io
+ DEPENDS:=+python3-light
+endef
+
+define Package/python3-sniffio/description
+ This is a tiny package whose only purpose is to let you detect which async library your code is running under.
+endef
+
+$(eval $(call Py3Package,python3-sniffio))
+$(eval $(call BuildPackage,python3-sniffio))
+$(eval $(call BuildPackage,python3-sniffio-src))