aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-slugify
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2019-03-27 16:13:33 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2019-04-01 01:28:53 +0200
commitd90516182b305d8cda1b0d266ce13321285782f2 (patch)
treea200e936805cc6abbffb2bf64a856f397defbefa /lang/python/python-slugify
parent0fa3ecd754f78557fbabb1dfabfadd460f007428 (diff)
python-slugify: add Python3 package
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'lang/python/python-slugify')
-rw-r--r--lang/python/python-slugify/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/lang/python/python-slugify/Makefile b/lang/python/python-slugify/Makefile
new file mode 100644
index 000000000..c7442e29c
--- /dev/null
+++ b/lang/python/python-slugify/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-slugify
+PKG_VERSION:=3.0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=python-slugify-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/p/python-slugify/
+PKG_HASH:=492b27e5a12495340e50652ab4eab3a229ef7167c44b66b3a2861450e68b269a
+
+PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-slugify
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Slugify application that handles Unicode
+ URL:=https://github.com/un33k/python-slugify
+ DEPENDS+= \
+ +python3-light \
+ +python3-text-unidecode
+ VARIANT:=python3
+endef
+
+define Package/python3-slugify/description
+A Python slugify application that handles unicode.
+endef
+
+$(eval $(call Py3Package,python3-slugify))
+$(eval $(call BuildPackage,python3-slugify))
+$(eval $(call BuildPackage,python3-slugify-src))