aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-six
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-02-20 15:19:26 +0800
committerJeffery To <jeffery.to@gmail.com>2019-02-20 19:19:20 +0800
commitf562ccf2ca56ad8b96b0eddb64515e4b2fbde392 (patch)
tree0a996ad6e963df892ced9517ca42c8b634612d4d /lang/python/python-six
parent0265390c9224b1ca226f1b1d68dbd2259192b034 (diff)
multiple-python-packages: Update package data
This updates the Python 2 and 3 versions of each package to share the same title field. (For packages that only had this change, their PKG_RELEASE were not incremented.) This also updates the package title, url and source urls, where necessary. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-six')
-rw-r--r--lang/python/python-six/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/python/python-six/Makefile b/lang/python/python-six/Makefile
index 033329137..354f72095 100644
--- a/lang/python/python-six/Makefile
+++ b/lang/python/python-six/Makefile
@@ -9,16 +9,17 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-six
PKG_VERSION:=1.12.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=six-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/s/six
PKG_HASH:=d16a0141ec1a18405cd4ce8b4613101da75da0e9a7aec5bdd4fa804d0e0eba73
+
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-six-$(PKG_VERSION)
-PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>, Alexandru Ardelean <ardeleanalex@gmail.com>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>, Alexandru Ardelean <ardeleanalex@gmail.com>
HOST_BUILD_DEPENDS:=python/host
@@ -34,19 +35,18 @@ define Package/python-six/Default
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
+ TITLE:=Python 2 and 3 compatibility library
URL:=https://github.com/benjaminp/six
endef
define Package/python-six
$(call Package/python-six/Default)
- TITLE:=python-six
DEPENDS:=+PACKAGE_python-six:python-light
VARIANT:=python
endef
define Package/python3-six
$(call Package/python-six/Default)
- TITLE:=python3-six
DEPENDS:=+PACKAGE_python3-six:python3-light
VARIANT:=python3
endef