aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-requests/Makefile
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2019-05-20 13:53:39 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2019-05-20 16:18:06 -0300
commit65009e8127414fe6796f8ace6d532750b622773a (patch)
tree10bc0c904b6fa36663fc10b522955fbc09e85c31 /lang/python/python-requests/Makefile
parent36d0c59e99ca1d71232156a677bf1b6fe3aea736 (diff)
treewide: Add PACKAGE_* conds to python packages
If a package builds python & python3 variants, then the respective PACKAGE-python* conditional DEPENDS were added, since circular dependencies should all be resolved now. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'lang/python/python-requests/Makefile')
-rw-r--r--lang/python/python-requests/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/lang/python/python-requests/Makefile b/lang/python/python-requests/Makefile
index 3c823893c..dd6df4fb1 100644
--- a/lang/python/python-requests/Makefile
+++ b/lang/python/python-requests/Makefile
@@ -52,11 +52,11 @@ endef
define Package/python3-requests
$(call Package/python-requests/Default)
DEPENDS:= \
- +python3-light \
- +python3-chardet \
- +python3-idna \
- +python3-urllib3 \
- +python3-certifi
+ +PACKAGE_python3-requests:python3-light \
+ +PACKAGE_python3-requests:python3-chardet \
+ +PACKAGE_python3-requests:python3-idna \
+ +PACKAGE_python3-requests:python3-urllib3 \
+ +PACKAGE_python3-requests:python3-certifi
VARIANT:=python3
endef