aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-requests/Makefile
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2018-06-23 16:55:05 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2018-06-23 16:55:05 -0300
commit01d9b705bcd12863c25c2db881d8239292aa6c2a (patch)
treec533427cfbffc12abfceca91538790bf3047fc91 /lang/python/python-requests/Makefile
parent2f6a99991dbeb4bf4779f78cc82c18e6d46022f7 (diff)
python-requests: add new package
HTTP library for Python. This package is a direct dependency of seafile-seahub. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'lang/python/python-requests/Makefile')
-rw-r--r--lang/python/python-requests/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/lang/python/python-requests/Makefile b/lang/python/python-requests/Makefile
new file mode 100644
index 000000000..e48271d02
--- /dev/null
+++ b/lang/python/python-requests/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2007-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-requests
+PKG_VERSION:=2.19.1
+PKG_RELEASE:=1
+PKG_LICENSE:=Apache-2.0
+
+PKG_SOURCE:=requests-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/54/1f/782a5734931ddf2e1494e4cd615a51ff98e1879cbe9eecbdfeaf09aa75e9
+PKG_HASH:=ec22d826a36ed72a7358ff3fe56cbd4ba69dd7a6718ffd450ff0e9df7a47ce6a
+PKG_BUILD_DIR:=$(BUILD_DIR)/requests-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../python-package.mk
+
+define Package/python-requests
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
+ TITLE:=HTTP library for Python
+ URL:=http://python-requests.org/
+ DEPENDS:=+python +chardet +python-idna +python-urllib3 +python-certifi
+endef
+
+define Package/python-requests/description
+ Requests is the only Non-GMO HTTP library for Python, safe for human consumption.
+endef
+
+define Build/Compile
+ $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+endef
+
+define Package/python-requests/install
+ $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
+ $(CP) \
+ $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
+ $(1)$(PYTHON_PKG_DIR)
+endef
+
+$(eval $(call BuildPackage,python-requests))