aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-pysocks
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2021-03-10 12:07:33 +0100
committerJan Pavlinec <jan.pavlinec@nic.cz>2021-03-10 12:07:47 +0100
commit780fc502d284976b3e9043586c29e41f79718384 (patch)
treef5495839fe05042e212b55c7326138f9100f23ef /lang/python/python-pysocks
parent31d37ec6d5e517cc1dd8fc3db4d3c24625838d49 (diff)
python-pysocks: add new package
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
Diffstat (limited to 'lang/python/python-pysocks')
-rw-r--r--lang/python/python-pysocks/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/lang/python/python-pysocks/Makefile b/lang/python/python-pysocks/Makefile
new file mode 100644
index 000000000..56ad79741
--- /dev/null
+++ b/lang/python/python-pysocks/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pysocks
+PKG_VERSION:=1.7.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=PySocks
+PKG_HASH:=3f8804571ebe159c380ac6de37643bb4685970655d3bba243530d6558b799aa0
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-pysocks
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Python SOCKS client module
+ URL:=https://github.com/Anorov/PySocks
+ DEPENDS:= \
+ +python3-light \
+ +python3-logging \
+ +python3-openssl \
+ +python3-urllib
+endef
+
+define Package/python3-pysocks/description
+ PySocks lets you send traffic through SOCKS proxy servers.
+ It is a modern fork of SocksiPy with bug fixes and extra features.
+endef
+
+$(eval $(call Py3Package,python3-pysocks))
+$(eval $(call BuildPackage,python3-pysocks))
+$(eval $(call BuildPackage,python3-pysocks-src))