aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-pyserial
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2019-05-20 13:53:39 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2019-05-20 16:18:06 -0300
commit65009e8127414fe6796f8ace6d532750b622773a (patch)
tree10bc0c904b6fa36663fc10b522955fbc09e85c31 /lang/python/python-pyserial
parent36d0c59e99ca1d71232156a677bf1b6fe3aea736 (diff)
treewide: Add PACKAGE_* conds to python packages
If a package builds python & python3 variants, then the respective PACKAGE-python* conditional DEPENDS were added, since circular dependencies should all be resolved now. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'lang/python/python-pyserial')
-rw-r--r--lang/python/python-pyserial/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/python/python-pyserial/Makefile b/lang/python/python-pyserial/Makefile
index 00b6410f9..8a25c1153 100644
--- a/lang/python/python-pyserial/Makefile
+++ b/lang/python/python-pyserial/Makefile
@@ -36,14 +36,14 @@ endef
define Package/python-pyserial
$(call Package/python-pyserial/Default)
TITLE:=python-pyserial
- DEPENDS:=+python-light
+ DEPENDS:=+PACKAGE_python-pyserial:python-light
VARIANT:=python
endef
define Package/python3-pyserial
$(call Package/python-pyserial/Default)
TITLE:=python3-pyserial
- DEPENDS:=+python3-light
+ DEPENDS:=+PACKAGE_python3-pyserial:python3-light
VARIANT:=python3
endef