aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-pyrsistent
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-08-19 04:36:38 +0800
committerTianling Shen <cnsztl@gmail.com>2023-08-24 17:20:58 +0800
commit383b8c1658c5f9e39e17352f857338d0e6b46d16 (patch)
tree3a0b6632cb02cd866bbff3c146fca47ef38dd199 /lang/python/python-pyrsistent
parentdbe5283ed07497eab5cc1fd3c29553747fec878b (diff)
python-pyrsistent: Update to 0.19.3, update list of dependencies
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-pyrsistent')
-rw-r--r--lang/python/python-pyrsistent/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/lang/python/python-pyrsistent/Makefile b/lang/python/python-pyrsistent/Makefile
index b9ae85d7e..64d687399 100644
--- a/lang/python/python-pyrsistent/Makefile
+++ b/lang/python/python-pyrsistent/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-pyrsistent
-PKG_VERSION:=0.16.0
+PKG_VERSION:=0.19.3
PKG_RELEASE:=1
PYPI_NAME:=pyrsistent
-PKG_HASH:=28669905fe725965daa16184933676547c5bb40a5153055a8dee2a4bd7933ad3
+PKG_HASH:=1a2994773706bbb4995c31a97bc94f1418314923bd1048c6d964837040376440
PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
PKG_LICENSE:=MIT
@@ -28,12 +28,13 @@ define Package/python3-pyrsistent
CATEGORY:=Languages
TITLE:=Persistent/Functional/Immutable data structures
URL:=https://github.com/tobgu/pyrsistent
- DEPENDS:=+python3-light +python3-six
+ DEPENDS:=+python3-light
endef
define Package/python3-pyrsistent/description
- Pyrsistent is a number of persistent collections (by some referred to as functional data structures).
- Persistent in the sense that they are immutable.
+Pyrsistent is a number of persistent collections (by some referred to as
+functional data structures). Persistent in the sense that they are
+immutable.
endef
$(eval $(call Py3Package,python3-pyrsistent))