aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-pyproject-hooks
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-02-28 15:05:07 +0800
committerJeffery To <jeffery.to@gmail.com>2023-03-31 13:01:51 +0800
commitf6d68782d99c6f1ddb1472e4eedc902e947de2f3 (patch)
treee3c9b8e1a6f53ca0c380dca2ace47af1f26c0421 /lang/python/python-pyproject-hooks
parent7d171049fde47161c67b2c2e905b833bc66613f0 (diff)
python-pyproject-hooks: Add new host-only package
From the README: This is a low-level library for calling build-backends in pyproject.toml-based project. It provides the basic functionality to help write tooling that generates distribution files from Python projects. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-pyproject-hooks')
-rw-r--r--lang/python/python-pyproject-hooks/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/lang/python/python-pyproject-hooks/Makefile b/lang/python/python-pyproject-hooks/Makefile
new file mode 100644
index 000000000..50b3780ed
--- /dev/null
+++ b/lang/python/python-pyproject-hooks/Makefile
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pyproject-hooks
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=pyproject_hooks
+PKG_HASH:=f271b298b97f5955d53fb12b72c1fb1948c22c1a6b70b315c54cedaca0264ef5
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_HOST_ONLY:=1
+HOST_BUILD_DEPENDS:=python3/host python-flit-core/host python-installer/host python-tomli/host
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include ../python3-package.mk
+include ../python3-host-build.mk
+
+define Package/python3-pyproject-hooks
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Wrappers to call pyproject.toml-based build backend hooks
+ URL:=https://github.com/pypa/pyproject-hooks
+ DEPENDS:=+python3-light
+ BUILDONLY:=1
+endef
+
+define Package/python3-pyproject-hooks/description
+This is a low-level library for calling build-backends in
+pyproject.toml-based project. It provides the basic functionality to
+help write tooling that generates distribution files from Python
+projects.
+endef
+
+Host/Compile=$(Py3Host/Compile/Bootstrap)
+
+$(eval $(call Py3Package,python3-pyproject-hooks))
+$(eval $(call BuildPackage,python3-pyproject-hooks))
+$(eval $(call BuildPackage,python3-pyproject-hooks-src))
+$(eval $(call HostBuild))