aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-pyparsing/Makefile
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2019-10-31 12:38:49 +0100
committerJan Pavlinec <jan.pavlinec@nic.cz>2019-11-01 12:49:18 +0100
commit455fe3dc034d9bedd82a5b959cdc5593d446dea3 (patch)
tree8e416341e753e8720a6911027e4133fc14a55b62 /lang/python/python-pyparsing/Makefile
parent5ae85b79526d4b0197d3581d349a2f7b6932bd52 (diff)
python-pyparsing: add new package
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
Diffstat (limited to 'lang/python/python-pyparsing/Makefile')
-rw-r--r--lang/python/python-pyparsing/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/lang/python/python-pyparsing/Makefile b/lang/python/python-pyparsing/Makefile
new file mode 100644
index 000000000..f4f3d114e
--- /dev/null
+++ b/lang/python/python-pyparsing/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2019 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pyparsing
+PKG_VERSION:=2.4.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=pyparsing
+PKG_HASH:=6f98a7b9397e206d78cc01df10131398f1c8b8510a2f4d97d9abd82e1aacdd80
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-pyparsing
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Library for constructing grammar directly in python
+ URL:=https://github.com/pyparsing/pyparsing/
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-pyparsing/description
+ The pyparsing module is an alternative approach to creating
+ and executing simple grammars, vs. the traditional lex/yacc
+ approach, or the use of regular expressions.
+ The pyparsing module provides a library of classes that
+ client code uses to construct the grammar directly in Python code.
+endef
+
+$(eval $(call Py3Package,python3-pyparsing))
+$(eval $(call BuildPackage,python3-pyparsing))
+$(eval $(call BuildPackage,python3-pyparsing-src))