aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-pyfuse3
diff options
context:
space:
mode:
authorJulien Malik <julien.malik@paraiso.me>2022-11-26 15:24:05 +0100
committerJulien Malik <julien.malik@paraiso.me>2022-11-26 15:24:05 +0100
commit17f58b94a745a9f058182822d420ed65b3730437 (patch)
treef59ad2d922b7a74d7586c5cad45bffee3dad2b70 /lang/python/python-pyfuse3
parent07e29c3782f5eb4fb0e3cc3cdf587c77eafb96e6 (diff)
python-pyfuse3: add package for 3.2.2
Signed-off-by: Julien Malik <julien.malik@paraiso.me>
Diffstat (limited to 'lang/python/python-pyfuse3')
-rw-r--r--lang/python/python-pyfuse3/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/lang/python/python-pyfuse3/Makefile b/lang/python/python-pyfuse3/Makefile
new file mode 100644
index 000000000..fd13ccfc0
--- /dev/null
+++ b/lang/python/python-pyfuse3/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2022 Julien Malik <julien.malik@paraiso.me>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pyfuse3
+PKG_VERSION:=3.2.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=pyfuse3
+PKG_HASH:=aa4080913e6148bff1365d4aaacdc96767b87a1e178031fd9caeb5f0b9fc8cec
+
+PKG_LICENSE:=LGPL-2.0-or-later
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Julien Malik <julien.malik@paraiso.me>
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-pyfuse3
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Python 3 bindings for libfuse 3 with async I/O support
+ URL:=https://github.com/libfuse/pyfuse3
+ DEPENDS:= \
+ +python3-light \
+ +python3-trio \
+ +libfuse3
+endef
+
+define Package/python3-pyfuse3/description
+ pyfuse3 is a set of Python 3 bindings for libfuse 3.
+
+ It provides an asynchronous API compatible with Trio and asyncio,
+ and enables you to easily write a full-featured Linux filesystem in Python.
+endef
+
+$(eval $(call Py3Package,python3-pyfuse3))
+$(eval $(call BuildPackage,python3-pyfuse3))
+$(eval $(call BuildPackage,python3-pyfuse3-src))