aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-pluggy/Makefile
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2019-11-01 18:36:16 +0100
committerJan Pavlinec <jan.pavlinec@nic.cz>2020-04-03 12:02:14 +0200
commitb4ca8aacccc9a9cbabaa733ea1db80a0d34c2786 (patch)
treed76b1842a0ed2512c87bf32e27590fe3452af372 /lang/python/python-pluggy/Makefile
parenteef3d14af786995dbc485efb0a9d623c7a3e8ea9 (diff)
python-pluggy: add new package
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
Diffstat (limited to 'lang/python/python-pluggy/Makefile')
-rw-r--r--lang/python/python-pluggy/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/lang/python/python-pluggy/Makefile b/lang/python/python-pluggy/Makefile
new file mode 100644
index 000000000..2c34fe425
--- /dev/null
+++ b/lang/python/python-pluggy/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pluggy
+PKG_VERSION:=0.13.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=pluggy
+PKG_HASH:=15b2acde666561e1298d71b523007ed7364de07029219b604cf808bfa1c765b0
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=setuptools-scm
+
+define Package/python3-pluggy
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Plugin and hook calling mechanisms for Python
+ URL:=https://github.com/pytest-dev/pluggy
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-pluggy/description
+ A minimalist production ready plugin system for python
+endef
+
+$(eval $(call Py3Package,python3-pluggy))
+$(eval $(call BuildPackage,python3-pluggy))
+$(eval $(call BuildPackage,python3-pluggy-src))