aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-pkgconfig
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-03-01 14:16:40 +0800
committerJeffery To <jeffery.to@gmail.com>2023-04-24 16:18:13 +0800
commitd7bc1deb0ef272fea2aa347f831e706d63c1b2eb (patch)
treebe909ed9cfae00b711e274ef90c1745ea95faffa /lang/python/python-pkgconfig
parent2f4b161e2828a645ac1bfc2a77e9506fe3c8772d (diff)
python-pkgconfig: Add new host-only package
From the README: pkgconfig is a Python module to interface with the pkg-config command line tool for Python 3.3+. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-pkgconfig')
-rw-r--r--lang/python/python-pkgconfig/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/lang/python/python-pkgconfig/Makefile b/lang/python/python-pkgconfig/Makefile
new file mode 100644
index 000000000..d20210363
--- /dev/null
+++ b/lang/python/python-pkgconfig/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pkgconfig
+PKG_VERSION:=1.5.5
+PKG_RELEASE:=1
+
+PYPI_NAME:=pkgconfig
+PKG_HASH:=deb4163ef11f75b520d822d9505c1f462761b4309b1bb713d08689759ea8b899
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_HOST_ONLY:=1
+HOST_BUILD_DEPENDS:=python3/host python-build/host python-installer/host python-poetry-core/host
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include ../python3-package.mk
+include ../python3-host-build.mk
+
+define Package/python3-pkgconfig
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Interface Python with pkg-config
+ URL:=https://github.com/matze/pkgconfig
+ DEPENDS:=+python3-light
+ BUILDONLY:=1
+endef
+
+define Package/python3-pkgconfig/description
+pkgconfig is a Python module to interface with the pkg-config command
+line tool for Python 3.3+.
+endef
+
+$(eval $(call Py3Package,python3-pkgconfig))
+$(eval $(call BuildPackage,python3-pkgconfig))
+$(eval $(call BuildPackage,python3-pkgconfig-src))
+$(eval $(call HostBuild))