aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-pip-conf
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-05-18 13:36:24 +0800
committerJeffery To <jeffery.to@gmail.com>2023-05-26 22:06:08 +0800
commiteee273507b868ad5f6f7e744d513c85330967906 (patch)
treebd942e3df1a9037a0c88655dff34ebfc3354faa8 /lang/python/python-pip-conf
parentd53475ac21cf79bef902b61fac69ffe25a3aad2f (diff)
python3: Split pip into separate source package
Packaging pip from a separate source package allows it to stay updated with upstream. Host pip will remain installed as part of python3. Host pip is used in a much more controlled way and so is less critical for it to track upstream. This also removes the python-pip-conf package and installs the pip.conf file as part of python3-pip. The patch 003-disable-pip-version-check.patch is originally from Debian: https://salsa.debian.org/python-team/packages/python-pip/-/blob/bb079efb8c6dd2c284eee94cf90e61bce19a6f73/debian/patches/disable-pip-version-check.patch pip was in a separate source package that was removed in a53d0c5a403d1669e2cf6c59c2be6a9d3ed633a0; this work is not based on that earlier package. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-pip-conf')
-rw-r--r--lang/python/python-pip-conf/Makefile36
-rw-r--r--lang/python/python-pip-conf/files/pip.conf3
2 files changed, 0 insertions, 39 deletions
diff --git a/lang/python/python-pip-conf/Makefile b/lang/python/python-pip-conf/Makefile
deleted file mode 100644
index b8ef7f6c5..000000000
--- a/lang/python/python-pip-conf/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-#
-# Copyright (C) 2017 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=python-pip-conf
-PKG_VERSION:=0.1
-PKG_RELEASE:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/python-pip-conf
- SUBMENU:=Python
- SECTION:=lang
- CATEGORY:=Languages
- TITLE:=Configuration file for pip/pip3
- URL:=https://pip.pypa.io
- MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
-endef
-
-define Package/python-pip-conf/description
- Configuration file for pip/pip3
-endef
-
-Build/Compile:=
-
-define Package/python-pip-conf/install
- $(INSTALL_DIR) $(1)/etc
- $(CP) ./files/pip.conf $(1)/etc
-endef
-
-$(eval $(call BuildPackage,python-pip-conf))
diff --git a/lang/python/python-pip-conf/files/pip.conf b/lang/python/python-pip-conf/files/pip.conf
deleted file mode 100644
index 89339e98a..000000000
--- a/lang/python/python-pip-conf/files/pip.conf
+++ /dev/null
@@ -1,3 +0,0 @@
-[global]
-cache-dir=/tmp/.cache
-log-file=/tmp/pip-log.txt