aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-paho-mqtt
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-21 03:03:12 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-30 23:16:18 +0800
commit635cb1309c4d52763c03bc00e7c367e06908b54f (patch)
treef4ab5d3c372741d39b2c0c9e9e34a0c007ca6d53 /lang/python/python-paho-mqtt
parent29ef2938d131ad862f28c2e6f09656351a4ca006 (diff)
treewide: Use pypi.mk for Python packages
This updates all Python packages that download their source from PyPi to use pypi.mk. This will allow future improvements/changes to pypi.mk to affect all relevant packages. This also makes it easier for future Python packages to start using pypi.mk, when it's clear how it is used in existing packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-paho-mqtt')
-rw-r--r--lang/python/python-paho-mqtt/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/lang/python/python-paho-mqtt/Makefile b/lang/python/python-paho-mqtt/Makefile
index 1988f9b15..c81dbc1cc 100644
--- a/lang/python/python-paho-mqtt/Makefile
+++ b/lang/python/python-paho-mqtt/Makefile
@@ -10,11 +10,10 @@ PKG_RELEASE:=1
PKG_LICENSE:=Eclipse Public License v1.0 / Eclipse Distribution License v1.0
PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>, Alexandru Ardelean <ardeleanalex@gmail.com>
-PKG_SOURCE:=paho-mqtt-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/25/63/db25e62979c2a716a74950c9ed658dce431b5cb01fde29eb6cba9489a904
+PYPI_NAME:=paho-mqtt
PKG_HASH:=e440a052b46d222e184be3be38676378722072fcd4dfd2c8f509fb861a7b0b79
-PKG_BUILD_DIR:=$(BUILD_DIR)/paho-mqtt-$(PKG_VERSION)
+include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk