aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-packaging
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-22 01:27:50 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-22 16:36:55 +0800
commit2210c4a60dd8fb6420f7bd3c6fe00ed0ae4c51be (patch)
treed04a75fdd503108d25ad29ff7e7128083ae5b855 /lang/python/python-packaging
parent124b966b3fb9c2cfbd6f6c3efa151eb6cf26d1d9 (diff)
python-packages: Clean up Makefiles
This removes: * Python 3 variants (VARIANT:=python3) * "for Python3" from package titles * Package selection condition from package dependencies, e.g. +PACKAGE_python3-six:python3-light replaced with +python3-light * "Default" package information sections, e.g. Package/python-six/Default removed and package details merged into Package/python3-six * "(Variant for Python3)" from package descriptions Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-packaging')
-rw-r--r--lang/python/python-packaging/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/lang/python/python-packaging/Makefile b/lang/python/python-packaging/Makefile
index c656b11aa..c88b46495 100644
--- a/lang/python/python-packaging/Makefile
+++ b/lang/python/python-packaging/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-packaging
PKG_VERSION:=20.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=packaging
PKG_HASH:=3c292b474fda1671ec57d46d739d072bfd495a4f51ad01a055121d81e952b7a3
@@ -28,7 +28,6 @@ define Package/python3-packaging
TITLE:=Core utilities for Python packages
URL:=https://github.com/pypa/packaging
DEPENDS:=+python3-light +python3-pyparsing +python3-six +python3-logging +python3-distutils
- VARIANT:=python3
endef
define Package/python3-packaging/description