aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-oauthlib
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-22 01:27:50 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-22 16:36:55 +0800
commit2210c4a60dd8fb6420f7bd3c6fe00ed0ae4c51be (patch)
treed04a75fdd503108d25ad29ff7e7128083ae5b855 /lang/python/python-oauthlib
parent124b966b3fb9c2cfbd6f6c3efa151eb6cf26d1d9 (diff)
python-packages: Clean up Makefiles
This removes: * Python 3 variants (VARIANT:=python3) * "for Python3" from package titles * Package selection condition from package dependencies, e.g. +PACKAGE_python3-six:python3-light replaced with +python3-light * "Default" package information sections, e.g. Package/python-six/Default removed and package details merged into Package/python3-six * "(Variant for Python3)" from package descriptions Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-oauthlib')
-rw-r--r--lang/python/python-oauthlib/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/lang/python/python-oauthlib/Makefile b/lang/python/python-oauthlib/Makefile
index 4fcd4cea9..c2fe25980 100644
--- a/lang/python/python-oauthlib/Makefile
+++ b/lang/python/python-oauthlib/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-oauthlib
PKG_VERSION:=3.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Eneas U de Queiroz <cotequeiroz@gmail.com>
PKG_LICENSE:=BSD-3-Clause
@@ -20,25 +20,18 @@ include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
-define Package/python-oauthlib/Default
+define Package/python3-oauthlib
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=OAuth request-signing logic for Python
URL:=https://github.com/oauthlib/oauthlib
-endef
-
-define Package/python3-oauthlib
- $(call Package/python-oauthlib/Default)
- DEPENDS:=+PACKAGE_python3-oauthlib:python3-light
- VARIANT:=python3
+ DEPENDS:=+python3-light
endef
define Package/python3-oauthlib/description
A generic, spec-compliant, thorough implementation of the OAuth request-signing
logic for Python
-.
-(Variant for Python3)
endef
$(eval $(call Py3Package,python3-oauthlib))