aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-multidict
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-08-12 01:47:53 +0800
committerJeffery To <jeffery.to@gmail.com>2023-08-12 01:47:53 +0800
commitd219b6d28fe240295cfff9027409e8ce6d3c80af (patch)
treec0851d67e4b4b5b8cd51a7b84bec546941ca2ebb /lang/python/python-multidict
parentfce22d0d842f6d859aced9324d50098eb44df1e2 (diff)
python-multidict: Update to 6.0.4, update list of dependencies
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-multidict')
-rw-r--r--lang/python/python-multidict/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/lang/python/python-multidict/Makefile b/lang/python/python-multidict/Makefile
index b757b2cda..67d1a4882 100644
--- a/lang/python/python-multidict/Makefile
+++ b/lang/python/python-multidict/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=multidict
-PKG_VERSION:=4.5.2
-PKG_RELEASE:=2
+PKG_NAME:=python-multidict
+PKG_VERSION:=6.0.4
+PKG_RELEASE:=1
-PYPI_NAME:=$(PKG_NAME)
-PKG_HASH:=024b8129695a952ebd93373e45b5d341dbb87c17ce49637b34000093f243dd4f
+PYPI_NAME:=multidict
+PKG_HASH:=3666906492efb76453c0e7b97f2cf459b0682e7402c0489a95484965dbc1da49
PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
PKG_LICENSE:=Apache-2.0
@@ -28,13 +28,12 @@ define Package/python3-multidict
SUBMENU:=Python
TITLE:=multidict implementation
URL:=https://github.com/aio-libs/multidict
- DEPENDS:= \
- +python3-light \
- +python3-attrs
+ DEPENDS:=+python3-light
endef
define Package/python3-multidict/description
-Multidict is dict-like collection of key-value pairs where key might be occurred more than once in the container.
+Multidict is dict-like collection of key-value pairs where key might be
+occurred more than once in the container.
endef
$(eval $(call Py3Package,python3-multidict))