aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-iniconfig/Makefile
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2020-08-04 14:29:15 +0200
committerJan Pavlinec <jan.pavlinec@nic.cz>2020-08-24 12:37:35 +0200
commit4713740366a7fdf1f9176307b4deb590b87ad263 (patch)
treea9952ae5529f30c3f560346d2a79b6d2e21f2448 /lang/python/python-iniconfig/Makefile
parentd0ef2feda1621ccd8c1187ff509d3100cc075e9a (diff)
python-iniconfig: add new package (pytest dependency)
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
Diffstat (limited to 'lang/python/python-iniconfig/Makefile')
-rw-r--r--lang/python/python-iniconfig/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/lang/python/python-iniconfig/Makefile b/lang/python/python-iniconfig/Makefile
new file mode 100644
index 000000000..b95cf3da3
--- /dev/null
+++ b/lang/python/python-iniconfig/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-iniconfig
+PKG_VERSION:=1.0.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=iniconfig
+PKG_HASH:=e5f92f89355a67de0595932a6c6c02ab4afddc6fcdc0bfc5becd0d60884d3f69
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_PARALLEL:=0
+HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=setuptools-scm
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-iniconfig
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Simple config-ini parser
+ URL:=https://github.com/RonnyPfannschmidt/iniconfig
+ DEPENDS:= +python3-light
+endef
+
+define Package/python3-iniconfig/description
+ iniconfig is a small and simple INI-file parser module.
+endef
+
+$(eval $(call Py3Package,python3-iniconfig))
+$(eval $(call BuildPackage,python3-iniconfig))
+$(eval $(call BuildPackage,python3-iniconfig-src))