aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-ifaddr
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2019-04-22 08:50:23 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2019-04-23 17:49:38 +0200
commit60b94e42177bd25ffd2d4b6e1fc5f83093c81a5b (patch)
treee5e7ab9560d0b2931d41938d477e4d6699dcf89a /lang/python/python-ifaddr
parent2275823e01b42c264f674a54193ef2f3a78b235a (diff)
python3-ifaddr: add a new package
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'lang/python/python-ifaddr')
-rw-r--r--lang/python/python-ifaddr/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/lang/python/python-ifaddr/Makefile b/lang/python/python-ifaddr/Makefile
new file mode 100644
index 000000000..14fb960b9
--- /dev/null
+++ b/lang/python/python-ifaddr/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-ifaddr
+PKG_VERSION:=0.1.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=ifaddr-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/i/ifaddr/
+PKG_HASH:=c19c64882a7ad51a394451dabcbbed72e98b5625ec1e79789924d5ea3e3ecb93
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/ifaddr-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE.txt
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-ifaddr
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Enumerate IP addresses on network adapters
+ URL:=https://github.com/pydron/ifaddr
+ DEPENDS:= \
+ +python3-light \
+ +python3-ctypes
+ VARIANT:=python3
+endef
+
+define Package/python3-ifaddr/description
+ ifaddr is a small Python library that allows you to find all the IPv4 and IPv6 addresses of the computer.
+endef
+
+$(eval $(call Py3Package,python3-ifaddr))
+$(eval $(call BuildPackage,python3-ifaddr))
+$(eval $(call BuildPackage,python3-ifaddr-src))