aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-idna
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-02-20 15:19:26 +0800
committerJeffery To <jeffery.to@gmail.com>2019-02-20 19:19:20 +0800
commitf562ccf2ca56ad8b96b0eddb64515e4b2fbde392 (patch)
tree0a996ad6e963df892ced9517ca42c8b634612d4d /lang/python/python-idna
parent0265390c9224b1ca226f1b1d68dbd2259192b034 (diff)
multiple-python-packages: Update package data
This updates the Python 2 and 3 versions of each package to share the same title field. (For packages that only had this change, their PKG_RELEASE were not incremented.) This also updates the package title, url and source urls, where necessary. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-idna')
-rw-r--r--lang/python/python-idna/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/lang/python/python-idna/Makefile b/lang/python/python-idna/Makefile
index 894e39ee5..d54b91d2d 100644
--- a/lang/python/python-idna/Makefile
+++ b/lang/python/python-idna/Makefile
@@ -9,16 +9,17 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=python-idna
PKG_VERSION:=2.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=idna-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/i/idna
PKG_HASH:=c357b3f628cf53ae2c4c05627ecc484553142ca23264e593d327bcde5e9c3407
+
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-idna-$(PKG_VERSION)
-PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>, Alexandru Ardelean <ardeleanalex@gmail.com>
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.rst
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>, Alexandru Ardelean <ardeleanalex@gmail.com>
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
@@ -30,20 +31,23 @@ define Package/python-idna/Default
SECTION:=lang
CATEGORY:=Languages
SUBMENU:=Python
+ TITLE:=IDNA library
URL:=https://github.com/kjd/idna
endef
define Package/python-idna
$(call Package/python-idna/Default)
- TITLE:=python-idna
- DEPENDS:=+PACKAGE_python-idna:python-light +PACKAGE_python-idna:python-codecs
+ DEPENDS:= \
+ +PACKAGE_python-idna:python-light \
+ +PACKAGE_python-idna:python-codecs
VARIANT:=python
endef
define Package/python3-idna
$(call Package/python-idna/Default)
- TITLE:=python3-idna
- DEPENDS:=+PACKAGE_python3-idna:python3-light +PACKAGE_python3-idna:python3-codecs
+ DEPENDS:= \
+ +PACKAGE_python3-idna:python3-light \
+ +PACKAGE_python3-idna:python3-codecs
VARIANT:=python3
endef