aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-idna
diff options
context:
space:
mode:
authorDaniel Santos <daniel.santos@pobox.com>2018-10-24 03:19:46 -0500
committerDaniel Santos <daniel.santos@pobox.com>2019-01-12 00:53:04 -0600
commita350edf1a907947af41d9c60efb4069fbd440452 (patch)
tree6c9379fbc91b6769e4cf2139fe850ca4e8bbfd0f /lang/python/python-idna
parent8cfbcfd7570a023dfac81f6678256dd8968b5c67 (diff)
python-idna: Add missing dependency on python(3)-codecs
This error is exposed when using python-minimal. Signed-off-by: Daniel Santos <daniel.santos@pobox.com>
Diffstat (limited to 'lang/python/python-idna')
-rw-r--r--lang/python/python-idna/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/lang/python/python-idna/Makefile b/lang/python/python-idna/Makefile
index 59130b037..894e39ee5 100644
--- a/lang/python/python-idna/Makefile
+++ b/lang/python/python-idna/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015-2018 OpenWrt.org
+# Copyright (C) 2015-2019 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -36,14 +36,14 @@ endef
define Package/python-idna
$(call Package/python-idna/Default)
TITLE:=python-idna
- DEPENDS:=+PACKAGE_python-idna:python-light
+ DEPENDS:=+PACKAGE_python-idna:python-light +PACKAGE_python-idna:python-codecs
VARIANT:=python
endef
define Package/python3-idna
$(call Package/python-idna/Default)
TITLE:=python3-idna
- DEPENDS:=+PACKAGE_python3-idna:python3-light
+ DEPENDS:=+PACKAGE_python3-idna:python3-light +PACKAGE_python3-idna:python3-codecs
VARIANT:=python3
endef