aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-idna
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2017-07-06 21:09:04 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2017-07-27 14:05:48 +0300
commit8291361cc7d43ec1cb8e71c0692095eb4f4be48b (patch)
treea03df40d171e4fd8631741a263271ea01f362eab /lang/python/python-idna
parent990ddfffe28b23ce87a3a5fa5a31f3c05925323e (diff)
python-idna: bump to version 2.5 and add python3 variant
And add myself as 2nd maintainer. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python/python-idna')
-rw-r--r--lang/python/python-idna/Makefile51
1 files changed, 35 insertions, 16 deletions
diff --git a/lang/python/python-idna/Makefile b/lang/python/python-idna/Makefile
index d95409668..e3413a252 100644
--- a/lang/python/python-idna/Makefile
+++ b/lang/python/python-idna/Makefile
@@ -7,30 +7,45 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=idna
-PKG_VERSION:=2.1
+PKG_NAME:=python-idna
+PKG_VERSION:=2.5
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/i/idna
-PKG_MD5SUM:=f6473caa9c5e0cc1ad3fd5d04c3c114b
-
-PKG_BUILD_DEPENDS:=python python-setuptools
+PKG_SOURCE:=idna-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://pypi.python.org/packages/d8/82/28a51052215014efc07feac7330ed758702fc0581347098a81699b5281cb
+PKG_HASH:=3cb5ce08046c4e3a560fc02f138d0ac63e00f8ce5901a56b32ec8b7994082aab
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.rst
-PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>, Alexandru Ardelean <ardeleanalex@gmail.com>
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-idna-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python-package.mk)
+$(call include_mk, python3-package.mk)
+
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
+define Package/python-idna/Default
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ URL:=https://github.com/kjd/idna
+endef
define Package/python-idna
- SECTION:=lang
- CATEGORY:=Languages
- SUBMENU:=Python
- TITLE:=python-idna
- URL:=https://github.com/kjd/idna
- DEPENDS:=+python-light
+$(call Package/python-idna/Default)
+ TITLE:=python-idna
+ DEPENDS:=+PACKAGE_python-idna:python-light
+ VARIANT:=python
+endef
+
+define Package/python3-idna
+$(call Package/python-idna/Default)
+ TITLE:=python3-idna
+ DEPENDS:=+PACKAGE_python3-idna:python3-light
+ VARIANT:=python3
endef
define Package/python-idna/description
@@ -40,9 +55,13 @@ is often referred to as "IDNA2008" and can produce different results
from the earlier standard from 2003.
endef
-define Build/Compile
- $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
+define Package/python3-idna/description
+$(call define Package/python-idna/description)
+.
+(Variant for Python3)
endef
$(eval $(call PyPackage,python-idna))
$(eval $(call BuildPackage,python-idna))
+$(eval $(call Py3Package,python3-idna))
+$(eval $(call BuildPackage,python3-idna))