aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-idna
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-11-28 09:13:57 +0800
committerTianling Shen <cnsztl@gmail.com>2023-11-30 12:58:06 +0800
commit7d1febb77fde235fd960ec3dbf021da52f618ecf (patch)
tree30e3a325b809409c17893dfe17fca75695ab5d10 /lang/python/python-idna
parent41e500535cade1552d65e040e723c0353059f481 (diff)
python-idna: Update to 3.6
This also adds a test.sh script for the packages feed CI. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-idna')
-rw-r--r--lang/python/python-idna/Makefile10
-rw-r--r--lang/python/python-idna/test.sh23
2 files changed, 27 insertions, 6 deletions
diff --git a/lang/python/python-idna/Makefile b/lang/python/python-idna/Makefile
index ee8738a61..33129b03a 100644
--- a/lang/python/python-idna/Makefile
+++ b/lang/python/python-idna/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-idna
-PKG_VERSION:=3.4
+PKG_VERSION:=3.6
PKG_RELEASE:=1
PYPI_NAME:=idna
-PKG_HASH:=814f528e8dead7d329833b91c5faa87d60bf71824cd12a7530b5526063d02cb4
+PKG_HASH:=9ecdbbd083b06798ae1e86adcbfe8ab1479cf864e4ee30fe4e46a003d12491ca
PKG_LICENSE:=BSD-3-Clause
-PKG_LICENSE_FILES:=LICENSE.rst
+PKG_LICENSE_FILES:=LICENSE.md
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
PKG_BUILD_DEPENDS:=python-flit-core/host
@@ -30,9 +30,7 @@ define Package/python3-idna
SUBMENU:=Python
TITLE:=IDNA library
URL:=https://github.com/kjd/idna
- DEPENDS:= \
- +python3-light \
- +python3-codecs
+ DEPENDS:=+python3-light +python3-codecs
endef
define Package/python3-idna/description
diff --git a/lang/python/python-idna/test.sh b/lang/python/python-idna/test.sh
new file mode 100644
index 000000000..85f779c23
--- /dev/null
+++ b/lang/python/python-idna/test.sh
@@ -0,0 +1,23 @@
+#!/bin/sh
+
+[ "$1" = python3-idna ] || exit 0
+
+python3 - << 'EOF'
+
+import idna
+import idna.codec
+
+assert idna.encode('ドメイン.テスト') == b'xn--eckwd4c7c.xn--zckzah'
+assert idna.decode('xn--eckwd4c7c.xn--zckzah') == 'ドメイン.テスト'
+
+assert 'домен.испытание'.encode('idna2008') == b'xn--d1acufc.xn--80akhbyknj4f'
+assert b'xn--d1acufc.xn--80akhbyknj4f'.decode('idna2008') == 'домен.испытание'
+
+assert idna.alabel('测试') == b'xn--0zwm56d'
+
+assert idna.encode('Königsgäßchen', uts46=True) == b'xn--knigsgchen-b4a3dun'
+assert idna.decode('xn--knigsgchen-b4a3dun') == 'königsgäßchen'
+
+assert idna.encode('Königsgäßchen', uts46=True, transitional=True) == b'xn--knigsgsschen-lcb0w'
+
+EOF