aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-idna
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-01 22:21:16 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-02 14:57:30 +0800
commit658b1b67587c4698f6a4c182e9afea7cb5fba2ee (patch)
tree94f402f8080841dc3a6c7f4a701d7aeb21a6f6b2 /lang/python/python-idna
parentc37b15e1c49cf27de8f34f43e93a7a5c184be9e0 (diff)
python-libraries: Remove Python 2 variants
The Python 2 variants will be added to the abandoned packages feed. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-idna')
-rw-r--r--lang/python/python-idna/Makefile19
1 files changed, 1 insertions, 18 deletions
diff --git a/lang/python/python-idna/Makefile b/lang/python/python-idna/Makefile
index 57b6d7abe..fe524b44b 100644
--- a/lang/python/python-idna/Makefile
+++ b/lang/python/python-idna/Makefile
@@ -20,7 +20,6 @@ PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>, Alexandru Ardelean <ardeleana
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
-include ../python-package.mk
include ../python3-package.mk
define Package/python-idna/Default
@@ -31,14 +30,6 @@ define Package/python-idna/Default
URL:=https://github.com/kjd/idna
endef
-define Package/python-idna
-$(call Package/python-idna/Default)
- DEPENDS:= \
- +PACKAGE_python-idna:python-light \
- +PACKAGE_python-idna:python-codecs
- VARIANT:=python
-endef
-
define Package/python3-idna
$(call Package/python-idna/Default)
DEPENDS:= \
@@ -47,23 +38,15 @@ $(call Package/python-idna/Default)
VARIANT:=python3
endef
-define Package/python-idna/description
+define Package/python3-idna/description
A library to support the Internationalised Domain Names in Applications
(IDNA) protocol as specified in RFC 5891. This version of the protocol
is often referred to as "IDNA2008" and can produce different results
from the earlier standard from 2003.
-endef
-
-define Package/python3-idna/description
-$(call Package/python-idna/description)
.
(Variant for Python3)
endef
-$(eval $(call PyPackage,python-idna))
-$(eval $(call BuildPackage,python-idna))
-$(eval $(call BuildPackage,python-idna-src))
-
$(eval $(call Py3Package,python3-idna))
$(eval $(call BuildPackage,python3-idna))
$(eval $(call BuildPackage,python3-idna-src))