aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-idna
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-21 03:03:12 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-30 23:16:18 +0800
commit635cb1309c4d52763c03bc00e7c367e06908b54f (patch)
treef4ab5d3c372741d39b2c0c9e9e34a0c007ca6d53 /lang/python/python-idna
parent29ef2938d131ad862f28c2e6f09656351a4ca006 (diff)
treewide: Use pypi.mk for Python packages
This updates all Python packages that download their source from PyPi to use pypi.mk. This will allow future improvements/changes to pypi.mk to affect all relevant packages. This also makes it easier for future Python packages to start using pypi.mk, when it's clear how it is used in existing packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-idna')
-rw-r--r--lang/python/python-idna/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/lang/python/python-idna/Makefile b/lang/python/python-idna/Makefile
index d54b91d2d..d70ae3907 100644
--- a/lang/python/python-idna/Makefile
+++ b/lang/python/python-idna/Makefile
@@ -11,22 +11,18 @@ PKG_NAME:=python-idna
PKG_VERSION:=2.8
PKG_RELEASE:=2
-PKG_SOURCE:=idna-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/i/idna
+PYPI_NAME:=idna
PKG_HASH:=c357b3f628cf53ae2c4c05627ecc484553142ca23264e593d327bcde5e9c3407
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-idna-$(PKG_VERSION)
-
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.rst
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>, Alexandru Ardelean <ardeleanalex@gmail.com>
+include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
include ../python3-package.mk
-PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
-
define Package/python-idna/Default
SECTION:=lang
CATEGORY:=Languages