aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-hatch-vcs
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-03-01 01:55:46 +0800
committerJeffery To <jeffery.to@gmail.com>2023-03-31 13:08:38 +0800
commitfb48859907be034284890e63901893c32db26b8c (patch)
treeb42f9a5fd08724581c373c82b7263967d35c4e48 /lang/python/python-hatch-vcs
parent5e832f44fc5d36fcb5b1f52f2bec60ccd3466efa (diff)
python-hatch-vcs: Add new host-only package
From the README: This provides a plugin for Hatch that uses your preferred version control system (like Git) to determine project versions. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-hatch-vcs')
-rw-r--r--lang/python/python-hatch-vcs/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/lang/python/python-hatch-vcs/Makefile b/lang/python/python-hatch-vcs/Makefile
new file mode 100644
index 000000000..39f890985
--- /dev/null
+++ b/lang/python/python-hatch-vcs/Makefile
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-hatch-vcs
+PKG_VERSION:=0.3.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=hatch-vcs
+PYPI_SOURCE_NAME:=hatch_vcs
+PKG_HASH:=cec5107cfce482c67f8bc96f18bbc320c9aa0d068180e14ad317bbee5a153fee
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE.txt
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_HOST_ONLY:=1
+HOST_BUILD_DEPENDS:= \
+ python3/host \
+ python-build/host \
+ python-installer/host \
+ python-hatchling/host \
+ python-setuptools-scm/host
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include ../python3-package.mk
+include ../python3-host-build.mk
+
+define Package/python3-hatch-vcs
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Hatch plugin for versioning with your preferred VCS
+ URL:=https://github.com/ofek/hatch-vcs
+ DEPENDS:=+python3-light +python3-hatchling +python3-setuptools-scm
+ BUILDONLY:=1
+endef
+
+define Package/python3-hatch-vcs/description
+This provides a plugin for Hatch that uses your preferred version
+control system (like Git) to determine project versions.
+endef
+
+$(eval $(call Py3Package,python3-hatch-vcs))
+$(eval $(call BuildPackage,python3-hatch-vcs))
+$(eval $(call BuildPackage,python3-hatch-vcs-src))
+$(eval $(call HostBuild))