aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-hatch-fancy-pypi-readme
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-03-01 02:02:57 +0800
committerJeffery To <jeffery.to@gmail.com>2023-03-31 13:08:39 +0800
commit6294cf26c7eaf76b97da8c1e29b86b31316fa054 (patch)
tree4a4ba524b1505c1d967de1f0fc5d3fe0e917c8bd /lang/python/python-hatch-fancy-pypi-readme
parentfb48859907be034284890e63901893c32db26b8c (diff)
python-hatch-fancy-pypi-readme: Add new host-only package
From the README: hatch-fancy-pypi-readme is a Hatch metadata plugin for everyone who cares about the first impression of their project’s PyPI landing page. It allows you to define your PyPI project description in terms of concatenated fragments that are based on static strings, files, and most importantly: parts of files defined using cut-off points or regular expressions. Once you’ve assembled your readme, you can additionally run regular expression-based substitutions over it. For instance to make relative links absolute or to linkify users and issue numbers in your changelog. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-hatch-fancy-pypi-readme')
-rw-r--r--lang/python/python-hatch-fancy-pypi-readme/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/lang/python/python-hatch-fancy-pypi-readme/Makefile b/lang/python/python-hatch-fancy-pypi-readme/Makefile
new file mode 100644
index 000000000..4a2ab871d
--- /dev/null
+++ b/lang/python/python-hatch-fancy-pypi-readme/Makefile
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-hatch-fancy-pypi-readme
+PKG_VERSION:=22.8.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=hatch-fancy-pypi-readme
+PYPI_SOURCE_NAME:=hatch_fancy_pypi_readme
+PKG_HASH:=da91282ca09601c18aded8e378daf8b578c70214866f0971156ee9bb9ce6c26a
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE.txt
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_HOST_ONLY:=1
+HOST_BUILD_DEPENDS:= \
+ python3/host \
+ python-build/host \
+ python-installer/host \
+ python-hatchling/host \
+ python-tomli/host
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include ../python3-package.mk
+include ../python3-host-build.mk
+
+define Package/python3-hatch-fancy-pypi-readme
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Fancy PyPI READMEs with Hatch
+ URL:=https://github.com/hynek/hatch-fancy-pypi-readme
+ DEPENDS:=+python3-light +python3-hatchling +python3-tomli
+ BUILDONLY:=1
+endef
+
+define Package/python3-hatch-fancy-pypi-readme/description
+hatch-fancy-pypi-readme is a Hatch metadata plugin for everyone who
+cares about the first impression of their project’s PyPI landing page.
+It allows you to define your PyPI project description in terms of
+concatenated fragments that are based on static strings, files, and most
+importantly: parts of files defined using cut-off points or regular
+expressions.
+
+Once you’ve assembled your readme, you can additionally run regular
+expression-based substitutions over it. For instance to make relative
+links absolute or to linkify users and issue numbers in your changelog.
+endef
+
+$(eval $(call Py3Package,python3-hatch-fancy-pypi-readme))
+$(eval $(call BuildPackage,python3-hatch-fancy-pypi-readme))
+$(eval $(call BuildPackage,python3-hatch-fancy-pypi-readme-src))
+$(eval $(call HostBuild))