aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-greenlet/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-03-23 08:39:01 +0100
committerAndre Heider <a.heider@gmail.com>2023-04-08 08:38:54 +0200
commit565866a47210c9711c29173052063779b6d3bcfc (patch)
tree7a4b5a526fdee62534e64d6da3525ae7fb079b1d /lang/python/python-greenlet/Makefile
parentc8e1dd7d6013700163b90896654d97d6d855a08b (diff)
treewide: refactor to use PKG_BUILD_FLAGS:=no-mips16
See commit 5c545bdb "treewide: replace PKG_USE_MIPS16:=0 with PKG_BUILD_FLAGS:=no-mips16" on the main repository. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'lang/python/python-greenlet/Makefile')
-rw-r--r--lang/python/python-greenlet/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/python/python-greenlet/Makefile b/lang/python/python-greenlet/Makefile
index 8c2d64b26..cc9b4f896 100644
--- a/lang/python/python-greenlet/Makefile
+++ b/lang/python/python-greenlet/Makefile
@@ -18,7 +18,7 @@ PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE
# FIXME: remove when GCC10 is the oldest supported compiler, or the issue goes away
-PKG_USE_MIPS16:=0
+PKG_BUILD_FLAGS:=no-mips16
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
@@ -42,7 +42,7 @@ define Package/python3-greenlet/description
endef
# FIXME: remove when GCC10 is the oldest supported compiler, or the issue goes away
-# This is required in addition to PKG_USE_MIPS16:=0 because otherwise MIPS16
+# This is required in addition to PKG_BUILD_FLAGS:=no-mips16 because otherwise MIPS16
# flags are inherited from the Python base package (via sysconfig module)
ifdef CONFIG_USE_MIPS16
TARGET_CFLAGS += -mno-mips16 -mno-interlink-mips16