aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-fnvhash
diff options
context:
space:
mode:
authorTimothy M. Ace <openwrt@timothyace.com>2023-11-16 09:35:15 -0500
committerTimothy M. Ace <openwrt@timothyace.com>2023-11-16 09:35:15 -0500
commita26395dce39e9b3b3d77b70bd84c2383ac566c8f (patch)
tree6a0ee2a833d8928da7cbb09c3cbb528cc16742d9 /lang/python/python-fnvhash
parenteabb6b8a747acb2292b81ff59417310f12e319f7 (diff)
python-fnvhash: Added for v0.1.0
Signed-off-by: Timothy M. Ace <openwrt@timothyace.com>
Diffstat (limited to 'lang/python/python-fnvhash')
-rw-r--r--lang/python/python-fnvhash/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/lang/python/python-fnvhash/Makefile b/lang/python/python-fnvhash/Makefile
new file mode 100644
index 000000000..b0c2316d2
--- /dev/null
+++ b/lang/python/python-fnvhash/Makefile
@@ -0,0 +1,33 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-fnvhash
+PKG_VERSION:=0.1.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=fnvhash
+PKG_HASH:=3e82d505054f9f3987b2b5b649f7e7b6f48349f6af8a1b8e4d66779699c85a8e
+
+PKG_MAINTAINER:=Timothy Ace <openwrt@timothyace.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-fnvhash
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Pure Python FNV hash implementation
+ URL:=https://github.com/znerol/py-fnvhash
+ DEPENDS:=+python3-light
+endef
+
+define Package/python3-fnvhash/description
+Pure Python implementation of the FNV hash family with 100% test coverage.
+endef
+
+$(eval $(call Py3Package,python3-fnvhash))
+$(eval $(call BuildPackage,python3-fnvhash))
+$(eval $(call BuildPackage,python3-fnvhash-src))