aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-fnv-hash-fast
diff options
context:
space:
mode:
authorTimothy M. Ace <openwrt@timothyace.com>2023-11-16 09:36:10 -0500
committerTimothy M. Ace <openwrt@timothyace.com>2023-11-16 09:36:10 -0500
commitf0f38827376fe24f2e5745c5952f3abe598598b7 (patch)
tree68c9343ff15c8a5c5627c490b4a83cc0543ac83a /lang/python/python-fnv-hash-fast
parenta26395dce39e9b3b3d77b70bd84c2383ac566c8f (diff)
python-fnv-hash-fast: Added for v0.5.0
Signed-off-by: Timothy M. Ace <openwrt@timothyace.com>
Diffstat (limited to 'lang/python/python-fnv-hash-fast')
-rw-r--r--lang/python/python-fnv-hash-fast/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/lang/python/python-fnv-hash-fast/Makefile b/lang/python/python-fnv-hash-fast/Makefile
new file mode 100644
index 000000000..b4758598e
--- /dev/null
+++ b/lang/python/python-fnv-hash-fast/Makefile
@@ -0,0 +1,38 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-fnv-hash-fast
+PKG_VERSION:=0.5.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=fnv-hash-fast
+PYPI_SOURCE_NAME:=fnv_hash_fast
+PKG_HASH:=a84d658952776a186418f4158fc8e55ff3c576ac32cc9ef7f8077efdf2d0b89f
+
+PKG_MAINTAINER:=Timothy Ace <openwrt@timothyace.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=python-cython/host python-poetry-core/host
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-fnv-hash-fast
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=A fast version of fnv1a
+ URL:=https://github.com/bdraco/fnv-hash-fast
+ DEPENDS:=+libstdcpp +python3-light +python3-fnvhash
+endef
+
+define Package/python3-fnv-hash-fast/description
+A fast version of fnv1a. This library will use a CPP implementation of fnv1a
+(32) if cython is available, and will fallback to pure python from the fnvhash
+package if it is not.
+endef
+
+$(eval $(call Py3Package,python3-fnv-hash-fast))
+$(eval $(call BuildPackage,python3-fnv-hash-fast))
+$(eval $(call BuildPackage,python3-fnv-hash-fast-src))