aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-flask-seasurf
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2020-10-17 16:14:07 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2020-10-29 15:20:04 +0100
commit979aeda8fb2858e0873d65c04abe3f70f5f6bad4 (patch)
treeb5ea37505f072cb415c45c6a63bbecdeb165e72c /lang/python/python-flask-seasurf
parentf3e723bd40f73b192a54ab727b8c00ad0b559b9e (diff)
python-flask-seasurf: add package
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
Diffstat (limited to 'lang/python/python-flask-seasurf')
-rw-r--r--lang/python/python-flask-seasurf/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/lang/python/python-flask-seasurf/Makefile b/lang/python/python-flask-seasurf/Makefile
new file mode 100644
index 000000000..c77026e32
--- /dev/null
+++ b/lang/python/python-flask-seasurf/Makefile
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2019-2020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-flask-seasurf
+PKG_VERSION:=0.2.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=Flask-SeaSurf
+PKG_HASH:=c57918c17e9afd988bdc30d8dcb7bfb833741dee38b06c1bbd17821d6fa2b6cf
+
+PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-flask-seasurf
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Flask SeaSurf
+ URL:=https://flask-seasurf.readthedocs.io/en/latest/
+ DEPENDS:= \
+ +python3-flask \
+ +python3-light \
+ +python3-urllib
+endef
+
+define Package/python3-flask-seasurf/description
+ SeaSurf is a Flask extension for preventing cross-site request forgery (CSRF).
+endef
+
+$(eval $(call Py3Package,python3-flask-seasurf))
+$(eval $(call BuildPackage,python3-flask-seasurf))
+$(eval $(call BuildPackage,python3-flask-seasurf-src))