aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-evdev
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-05-27 19:43:57 +0800
committerRosen Penev <rosenp@gmail.com>2023-05-28 09:30:31 +0300
commitb76fa19b26027f8472617598c19b9e071eef81bb (patch)
tree314d74d7a60145e01b596344d8f6fd9d8da7a21f /lang/python/python-evdev
parent0e34107963e3d503ed4dd7a9b9dc6b75596d5474 (diff)
python-packages: Replace --global-option with --build-option
setuptools 64.0.0 deprecated the use of --global-option to pass build parameters[1]. This replaces the use of --global-option with --build-option. [1]: https://github.com/pypa/setuptools/blob/main/CHANGES.rst#v6400 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-evdev')
-rw-r--r--lang/python/python-evdev/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/python/python-evdev/Makefile b/lang/python/python-evdev/Makefile
index bab726b54..4623adae7 100644
--- a/lang/python/python-evdev/Makefile
+++ b/lang/python/python-evdev/Makefile
@@ -40,10 +40,10 @@ endef
LINUX_EVDEV_HEADERS="$(LINUX_DIR)/include/uapi/linux/input.h:$(LINUX_DIR)/include/uapi/linux/input-event-codes.h"
PYTHON3_PKG_BUILD_CONFIG_SETTINGS:= \
- --global-option=build \
- --global-option=build_ecodes \
- --global-option=--evdev-headers="$(LINUX_EVDEV_HEADERS)" \
- --global-option=build_ext
+ --build-option=build \
+ --build-option=build_ecodes \
+ --build-option=--evdev-headers="$(LINUX_EVDEV_HEADERS)" \
+ --build-option=build_ext
$(eval $(call Py3Package,python3-evdev))
$(eval $(call BuildPackage,python3-evdev))