aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-evdev
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2019-04-24 11:56:15 +0300
committerAlexandru Ardelean <ardeleanalex@gmail.com>2019-04-25 10:44:14 +0300
commit83c349caee6b9cd0df92122df7596d8455a08725 (patch)
tree57e50678059b36efb89b398b41ac19376c167c3b /lang/python/python-evdev
parent3e961f76893c1bf8b81871a99c37eb7b9e589f3c (diff)
python-evdev: use PYTHON[3]_PKG_SETUP_GLOBAL_ARGS vars for build
This is a minor cleanup. Use PYTHON[3]_PKG_SETUP_GLOBAL_ARGS variable to specify extra build args. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'lang/python/python-evdev')
-rw-r--r--lang/python/python-evdev/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/lang/python/python-evdev/Makefile b/lang/python/python-evdev/Makefile
index 38ba1ae70..6f062d1c5 100644
--- a/lang/python/python-evdev/Makefile
+++ b/lang/python/python-evdev/Makefile
@@ -63,19 +63,14 @@ $(call Package/python-evdev/description)
(Variant for Python3)
endef
-define PyBuild/Compile
- $(call Build/Compile/PyMod,, build \
- build_ecodes --evdev-headers="$(LINUX_DIR)/include/uapi/linux/input.h:$(LINUX_DIR)/include/uapi/linux/input-event-codes.h" \
- build_ext \
- install --root="$(PKG_INSTALL_DIR)" --prefix="/usr")
-endef
+LINUX_EVDEV_HEADERS="$(LINUX_DIR)/include/uapi/linux/input.h:$(LINUX_DIR)/include/uapi/linux/input-event-codes.h"
-define Py3Build/Compile
- $(call Build/Compile/Py3Mod,, build \
- build_ecodes --evdev-headers="$(LINUX_DIR)/include/uapi/linux/input.h:$(LINUX_DIR)/include/uapi/linux/input-event-codes.h" \
- build_ext \
- install --root="$(PKG_INSTALL_DIR)" --prefix="/usr")
-endef
+PYTHON3_PKG_SETUP_GLOBAL_ARGS:= \
+ build build_ecodes \
+ --evdev-headers="$(LINUX_EVDEV_HEADERS)" \
+ build_ext
+
+PYTHON_PKG_SETUP_GLOBAL_ARGS:=$(PYTHON3_PKG_SETUP_GLOBAL_ARGS)
$(eval $(call PyPackage,python-evdev))
$(eval $(call BuildPackage,python-evdev))