aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-evdev
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-03-06 11:54:02 +0800
committerJeffery To <jeffery.to@gmail.com>2023-04-24 16:20:35 +0800
commit63d13aa15f847d35d7f7473e1595de6c9d53f655 (patch)
tree71a1de6365b5561ba0d0937336a8bffa1f2ebbd8 /lang/python/python-evdev
parent30bd279461faf52b153714eac28b613eef594b90 (diff)
python-libraries: Update build options
This updates the build options for these packages to work with the pyproject.toml-based build process, and removes PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-evdev')
-rw-r--r--lang/python/python-evdev/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/lang/python/python-evdev/Makefile b/lang/python/python-evdev/Makefile
index 6463daec7..bab726b54 100644
--- a/lang/python/python-evdev/Makefile
+++ b/lang/python/python-evdev/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=python-evdev
PKG_VERSION:=1.6.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=BSD-3-Clause
PKG_MAINTAINER:=Paulo Costa <me@paulo.costa.nom.br>, Alexandru Ardelean <ardeleanalex@gmail.com>
@@ -18,8 +18,6 @@ PKG_MAINTAINER:=Paulo Costa <me@paulo.costa.nom.br>, Alexandru Ardelean <ardelea
PYPI_NAME:=evdev
PKG_HASH:=299db8628cc73b237fc1cc57d3c2948faa0756e2a58b6194b5bf81dc2081f1e3
-PYTHON3_PKG_FORCE_DISTUTILS_SETUP:=1
-
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
@@ -41,10 +39,11 @@ endef
LINUX_EVDEV_HEADERS="$(LINUX_DIR)/include/uapi/linux/input.h:$(LINUX_DIR)/include/uapi/linux/input-event-codes.h"
-PYTHON3_PKG_SETUP_GLOBAL_ARGS:= \
- build build_ecodes \
- --evdev-headers="$(LINUX_EVDEV_HEADERS)" \
- build_ext
+PYTHON3_PKG_BUILD_CONFIG_SETTINGS:= \
+ --global-option=build \
+ --global-option=build_ecodes \
+ --global-option=--evdev-headers="$(LINUX_EVDEV_HEADERS)" \
+ --global-option=build_ext
$(eval $(call Py3Package,python3-evdev))
$(eval $(call BuildPackage,python3-evdev))