aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-evdev
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-22 01:27:50 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-22 16:36:55 +0800
commit2210c4a60dd8fb6420f7bd3c6fe00ed0ae4c51be (patch)
treed04a75fdd503108d25ad29ff7e7128083ae5b855 /lang/python/python-evdev
parent124b966b3fb9c2cfbd6f6c3efa151eb6cf26d1d9 (diff)
python-packages: Clean up Makefiles
This removes: * Python 3 variants (VARIANT:=python3) * "for Python3" from package titles * Package selection condition from package dependencies, e.g. +PACKAGE_python3-six:python3-light replaced with +python3-light * "Default" package information sections, e.g. Package/python-six/Default removed and package details merged into Package/python3-six * "(Variant for Python3)" from package descriptions Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-evdev')
-rw-r--r--lang/python/python-evdev/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/lang/python/python-evdev/Makefile b/lang/python/python-evdev/Makefile
index 037d26c92..0a64927c3 100644
--- a/lang/python/python-evdev/Makefile
+++ b/lang/python/python-evdev/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=python-evdev
PKG_VERSION:=1.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=BSD-3-Clause
PKG_MAINTAINER:=Paulo Costa <me@paulo.costa.nom.br>, Alexandru Ardelean <ardeleanalex@gmail.com>
@@ -22,26 +22,19 @@ include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
-define Package/python-evdev/Default
+define Package/python3-evdev
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
- URL:=https://github.com/gvalkov/python-evdev
-endef
-
-define Package/python3-evdev
-$(call Package/python-evdev/Default)
TITLE:=python3-evdev
+ URL:=https://github.com/gvalkov/python-evdev
DEPENDS:= \
- +PACKAGE_python3-evdev:python3-light \
- +PACKAGE_python3-evdev:python3-ctypes
- VARIANT:=python3
+ +python3-light \
+ +python3-ctypes
endef
define Package/python3-evdev/description
Bindings to the Linux input handling subsystem
-.
-(Variant for Python3)
endef
LINUX_EVDEV_HEADERS="$(LINUX_DIR)/include/uapi/linux/input.h:$(LINUX_DIR)/include/uapi/linux/input-event-codes.h"