aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-docutils
diff options
context:
space:
mode:
authorDaniel Danzberger <daniel@dd-wrt.com>2019-04-04 13:59:13 +0200
committerDaniel Danzberger <daniel@dd-wrt.com>2019-04-19 11:43:14 +0200
commit542800e401d43939ca3991562598445a8b90238a (patch)
tree08cb8240385eea50de2769439c7d1ca62ec83f29 /lang/python/python-docutils
parent55dd6b5fee7fc92acde38856b814bb564702ef2e (diff)
python-docutils: Add new package
Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
Diffstat (limited to 'lang/python/python-docutils')
-rw-r--r--lang/python/python-docutils/Makefile62
1 files changed, 62 insertions, 0 deletions
diff --git a/lang/python/python-docutils/Makefile b/lang/python/python-docutils/Makefile
new file mode 100644
index 000000000..f7bbe3297
--- /dev/null
+++ b/lang/python/python-docutils/Makefile
@@ -0,0 +1,62 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=docutils
+PKG_VERSION:=0.14
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/d/docutils
+PKG_HASH:=51e64ef2ebfb29cae1faa133b3710143496eca21c530f3f71424d77687764274
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-docutils-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Daniel Danzberger <daniel@dd-wrt.com>
+PKG_LICENSE:=MIT
+
+include $(INCLUDE_DIR)/package.mk
+include ../python-package.mk
+include ../python3-package.mk
+
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
+
+define Package/python-docutils/Default
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=docutils
+ URL:=http://docutils.sourceforge.net
+endef
+
+define Package/python-docutils
+$(call Package/python-docutils/Default)
+ DEPENDS:=+python
+ VARIANT:=python
+endef
+
+define Package/python3-docutils
+$(call Package/python-docutils/Default)
+ DEPENDS:=+python3
+ VARIANT:=python3
+endef
+
+define Package/python-docutils/description
+Docutils is a modular system for processing documentation into useful formats,
+such as HTML, XML, and LaTeX. For input Docutils supports reStructuredText,
+an easy-to-read, what-you-see-is-what-you-get plaintext markup syntax.
+endef
+
+define Package/python3-docutils/description
+$(call Package/python-docutils/description)
+.
+(Variant for Python3)
+endef
+
+PYTHON_PKG_SETUP_ARGS:=
+PYTHON3_PKG_SETUP_ARGS:=
+
+$(eval $(call PyPackage,python-docutils))
+$(eval $(call BuildPackage,python-docutils))
+$(eval $(call BuildPackage,python-docutils-src))
+
+$(eval $(call Py3Package,python3-docutils))
+$(eval $(call BuildPackage,python3-docutils))
+$(eval $(call BuildPackage,python3-docutils-src))