aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-docutils/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-22 01:27:50 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-22 16:36:55 +0800
commit2210c4a60dd8fb6420f7bd3c6fe00ed0ae4c51be (patch)
treed04a75fdd503108d25ad29ff7e7128083ae5b855 /lang/python/python-docutils/Makefile
parent124b966b3fb9c2cfbd6f6c3efa151eb6cf26d1d9 (diff)
python-packages: Clean up Makefiles
This removes: * Python 3 variants (VARIANT:=python3) * "for Python3" from package titles * Package selection condition from package dependencies, e.g. +PACKAGE_python3-six:python3-light replaced with +python3-light * "Default" package information sections, e.g. Package/python-six/Default removed and package details merged into Package/python3-six * "(Variant for Python3)" from package descriptions Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-docutils/Makefile')
-rw-r--r--lang/python/python-docutils/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/lang/python/python-docutils/Makefile b/lang/python/python-docutils/Makefile
index 4cc9c2534..04e4d756e 100644
--- a/lang/python/python-docutils/Makefile
+++ b/lang/python/python-docutils/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=docutils
PKG_VERSION:=0.14
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=51e64ef2ebfb29cae1faa133b3710143496eca21c530f3f71424d77687764274
@@ -14,26 +14,19 @@ include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python3-package.mk
-define Package/python-docutils/Default
+define Package/python3-docutils
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
TITLE:=docutils
URL:=http://docutils.sourceforge.net
-endef
-
-define Package/python3-docutils
-$(call Package/python-docutils/Default)
- DEPENDS:=+PACKAGE_python3-docutils:python3
- VARIANT:=python3
+ DEPENDS:=+python3
endef
define Package/python3-docutils/description
Docutils is a modular system for processing documentation into useful formats,
such as HTML, XML, and LaTeX. For input Docutils supports reStructuredText,
an easy-to-read, what-you-see-is-what-you-get plaintext markup syntax.
-.
-(Variant for Python3)
endef
PYTHON3_PKG_SETUP_ARGS:=