aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-dns/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-01 22:21:16 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-02 14:57:30 +0800
commit658b1b67587c4698f6a4c182e9afea7cb5fba2ee (patch)
tree94f402f8080841dc3a6c7f4a701d7aeb21a6f6b2 /lang/python/python-dns/Makefile
parentc37b15e1c49cf27de8f34f43e93a7a5c184be9e0 (diff)
python-libraries: Remove Python 2 variants
The Python 2 variants will be added to the abandoned packages feed. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-dns/Makefile')
-rw-r--r--lang/python/python-dns/Makefile16
1 files changed, 1 insertions, 15 deletions
diff --git a/lang/python/python-dns/Makefile b/lang/python/python-dns/Makefile
index bb93b85e5..a7837131a 100644
--- a/lang/python/python-dns/Makefile
+++ b/lang/python/python-dns/Makefile
@@ -23,7 +23,6 @@ PKG_CPE_ID:=cpe:/a:debian:python-dns
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-dnspython-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
-include ../python-package.mk
include ../python3-package.mk
PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
@@ -36,16 +35,6 @@ define Package/python-dns/Default
URL:=http://www.dnspython.org/
endef
-define Package/python-dns
-$(call Package/python-dns/Default)
- DEPENDS:=+PACKAGE_python-dns:python
- VARIANT:=python
-endef
-
-define Package/python-dns/description
- dnspython is a DNS toolkit for Python. It supports almost all record types. It can be used for queries, zone transfers, and dynamic updates. It supports TSIG authenticated messages and EDNS0.
-endef
-
define Package/python3-dns
$(call Package/python-dns/Default)
DEPENDS:=+PACKAGE_python3-dns:python3
@@ -53,14 +42,11 @@ $(call Package/python-dns/Default)
endef
define Package/python3-dns/description
-$(call Package/python-dns/description)
+ dnspython is a DNS toolkit for Python. It supports almost all record types. It can be used for queries, zone transfers, and dynamic updates. It supports TSIG authenticated messages and EDNS0.
.
(Variant for Python3)
endef
-$(eval $(call PyPackage,python-dns))
-$(eval $(call BuildPackage,python-dns))
-$(eval $(call BuildPackage,python-dns-src))
$(eval $(call Py3Package,python3-dns))
$(eval $(call BuildPackage,python3-dns))
$(eval $(call BuildPackage,python3-dns-src))