aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-dns/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-07-28 02:18:52 +0800
committerTianling Shen <cnsztl@gmail.com>2023-08-04 01:58:29 +0800
commit03f78eff74a5e37a61314e27f428768aeddbba46 (patch)
tree1702c405e85ee6c7a457f264103b6a6597c2585d /lang/python/python-dns/Makefile
parentc0552ae0d411c4768a1e9b9500e1570d86761b13 (diff)
python-dns: Update to 2.4.1
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-dns/Makefile')
-rw-r--r--lang/python/python-dns/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/lang/python/python-dns/Makefile b/lang/python/python-dns/Makefile
index f303733b6..03fbffee6 100644
--- a/lang/python/python-dns/Makefile
+++ b/lang/python/python-dns/Makefile
@@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-dns
-PKG_VERSION:=2.3.0
+PKG_VERSION:=2.4.1
PKG_RELEASE:=1
PYPI_NAME:=dnspython
-PKG_HASH:=224e32b03eb46be70e12ef6d64e0be123a64e621ab4c0822ff6d450d52a540b9
+PKG_HASH:=c33971c79af5be968bb897e95c2448e11a645ee84d93b265ce0b7aabe5dfdca8
PKG_LICENSE:=ISC
PKG_LICENSE_FILES:=LICENSE
@@ -28,13 +28,15 @@ define Package/python3-dns
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
- TITLE:=dnspython
- URL:=http://www.dnspython.org/
+ TITLE:=DNS toolkit
+ URL:=https://www.dnspython.org/
DEPENDS:=+python3
endef
define Package/python3-dns/description
- dnspython is a DNS toolkit for Python. It supports almost all record types. It can be used for queries, zone transfers, and dynamic updates. It supports TSIG authenticated messages and EDNS0.
+dnspython is a DNS toolkit for Python. It supports almost all record
+types. It can be used for queries, zone transfers, and dynamic updates.
+It supports TSIG authenticated messages and EDNS0.
endef
$(eval $(call Py3Package,python3-dns))