aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-dateutil/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-01 22:21:16 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-02 14:57:30 +0800
commit658b1b67587c4698f6a4c182e9afea7cb5fba2ee (patch)
tree94f402f8080841dc3a6c7f4a701d7aeb21a6f6b2 /lang/python/python-dateutil/Makefile
parentc37b15e1c49cf27de8f34f43e93a7a5c184be9e0 (diff)
python-libraries: Remove Python 2 variants
The Python 2 variants will be added to the abandoned packages feed. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-dateutil/Makefile')
-rw-r--r--lang/python/python-dateutil/Makefile16
1 files changed, 1 insertions, 15 deletions
diff --git a/lang/python/python-dateutil/Makefile b/lang/python/python-dateutil/Makefile
index 8b5601eaf..5427f1772 100644
--- a/lang/python/python-dateutil/Makefile
+++ b/lang/python/python-dateutil/Makefile
@@ -19,7 +19,6 @@ PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
-include ../python-package.mk
include ../python3-package.mk
define Package/python-dateutil/Default
@@ -30,16 +29,6 @@ define Package/python-dateutil/Default
URL:=https://dateutil.readthedocs.org/
endef
-define Package/python-dateutil
-$(call Package/python-dateutil/Default)
- DEPENDS:=+PACKAGE_python-dateutil:python +PACKAGE_python-dateutil:python-six
- VARIANT:=python
-endef
-
-define Package/python-dateutil/description
- Extensions to the standard Python datetime module
-endef
-
define Package/python3-dateutil
$(call Package/python-dateutil/Default)
DEPENDS:=+PACKAGE_python3-dateutil:python3 +PACKAGE_python3-dateutil:python3-six
@@ -47,14 +36,11 @@ $(call Package/python-dateutil/Default)
endef
define Package/python3-dateutil/description
-$(call Package/python-dateutil/description)
+ Extensions to the standard Python datetime module
.
(Variant for Python3)
endef
-$(eval $(call PyPackage,python-dateutil))
-$(eval $(call BuildPackage,python-dateutil))
-$(eval $(call BuildPackage,python-dateutil-src))
$(eval $(call Py3Package,python3-dateutil))
$(eval $(call BuildPackage,python3-dateutil))
$(eval $(call BuildPackage,python3-dateutil-src))