aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-curl
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-03-06 22:29:15 +0800
committerJeffery To <jeffery.to@gmail.com>2023-04-24 16:22:03 +0800
commitb1b008f42ff0a6da96b801e2eaf68be4e2f2b5bb (patch)
treea231436c11d9cbf74eda9d155b463d5595a77e37 /lang/python/python-curl
parent63d13aa15f847d35d7f7473e1595de6c9d53f655 (diff)
python-packages: Clean up build variables
* Rename PYTHON3_PKG_SETUP_VARS to PYTHON3_PKG_BUILD_VARS, and PYTHON3_PKG_SETUP_DIR to PYTHON3_PKG_BUILD_PATH The new variable names emphasize that these values apply to the new build process. * Remove PYTHON3_PKG_SETUP_ARGS set to the empty string These were set to override the default arguments in the old build process and not applicable to the new build process. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-curl')
-rw-r--r--lang/python/python-curl/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/lang/python/python-curl/Makefile b/lang/python/python-curl/Makefile
index 7d8d69e82..b239efd3a 100644
--- a/lang/python/python-curl/Makefile
+++ b/lang/python/python-curl/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pycurl
PKG_VERSION:=7.45.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=5730590be0271364a5bddd9e245c9cc0fb710c4cbacbdd95264a3122d23224ca
@@ -32,8 +32,6 @@ define Package/python3-curl/description
PycURL is a Python interface to libcurl, the multiprotocol file transfer library.
endef
-PYTHON3_PKG_SETUP_ARGS:=
-
ifdef CONFIG_LIBCURL_OPENSSL
PYTHON3_PKG_BUILD_VARS:=PYCURL_SSL_LIBRARY=openssl
endif