aboutsummaryrefslogtreecommitdiff
path: root/lang/python/python-curl
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-21 03:03:12 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-30 23:16:18 +0800
commit635cb1309c4d52763c03bc00e7c367e06908b54f (patch)
treef4ab5d3c372741d39b2c0c9e9e34a0c007ca6d53 /lang/python/python-curl
parent29ef2938d131ad862f28c2e6f09656351a4ca006 (diff)
treewide: Use pypi.mk for Python packages
This updates all Python packages that download their source from PyPi to use pypi.mk. This will allow future improvements/changes to pypi.mk to affect all relevant packages. This also makes it easier for future Python packages to start using pypi.mk, when it's clear how it is used in existing packages. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'lang/python/python-curl')
-rw-r--r--lang/python/python-curl/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/lang/python/python-curl/Makefile b/lang/python/python-curl/Makefile
index c6aba22c6..690685967 100644
--- a/lang/python/python-curl/Makefile
+++ b/lang/python/python-curl/Makefile
@@ -8,22 +8,18 @@ PKG_NAME:=pycurl
PKG_VERSION:=7.43.0.3
PKG_RELEASE:=1
-PKG_SOURCE:=pycurl-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/p/pycurl
+PYPI_NAME:=$(PKG_NAME)
PKG_HASH:=6f08330c5cf79fa8ef68b9912b9901db7ffd34b63e225dce74db56bb21deda8e
PKG_MAINTAINER:=Waldemar Konik <informatyk74@interia.pl>
PKG_LICENSE:=LGPL-2.1
PKG_LICENSE_FILES:=COPYING-LGPL
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-curl-$(PKG_VERSION)
-
+include ../pypi.mk
include $(INCLUDE_DIR)/package.mk
include ../python-package.mk
include ../python3-package.mk
-PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
-
define Package/python-curl/Default
CATEGORY:=Languages
SECTION:=lang